PAT A1089

  • 题目:
    According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

  • 题目大意
    给定一个序列以及部分排序后的序列,判断排序是插入排序还是归并排序,并输出下一排序后的序列

  • 分析
    直接模拟插入排序和归并排序的每一步,在每一步结束之后将其和B序列比较,以此来判断是插入排序还是归并排序,并输出下一排序后的序列。

代码实现:

#include <cstdio>
#include <algorithm>
const int Max = 101;
using namespace std;
void Insert(int A[], int n){         //一次插入
    int temp = A[n], j;
    for( j = n; A[j-1] > temp &&j > 0; j--)
        A[j] = A[j-1];
    A[j] = temp;

}
void show(int A[], int n){           //输出数组元素
    printf("%d", A[0]);
    for(int i = 1; i < n; i++)
        printf(" %d", A[i]);
}
bool is_Insert(int A[], int B[], int n){        
    for(int i = 1; i < n; i++){
        bool tag = true;
        Insert(A, i);
        for(int j = 0; j < n; j++){
            if(A[j] != B[j]){
                tag = false;
                break;
            }
        }
        if(tag){
            Insert(A, i+1);
            printf("Insertion Sort\n");
            show(A, n);
            return true;

        }
    }
    return false;
}
void Merge(int A[], int B[], int n){        //归并排序
    for(int step = 2; step/2 <= n; step *= 2){
        bool tag = true;                   //判断在哪一步之后归并
        for(int i = 0; i < n; i += step)
            sort(A+i, A + min(i+step, n));
        for(int j = 0; j < n; j++)
            if(A[j] != B[j]){
                tag = false;
                break;
            }
        if(tag){
            step *= 2;
            for(int i = 0; i < n; i += step)
                sort(A+i, A + min(i+step, n));
            printf("Merge Sort\n");
            show(A, n);
            break;
        }
    }
}
int main(){
    int n, A[Max], B[Max], temp[Max];
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &A[i]);
        temp[i] = A[i];
    }
    for(int i = 0; i < n; i++)
        scanf("%d", &B[i]);
    bool res =  is_Insert(A, B, n);
    if(res)
        return 0;
    for(int i = 0; i < n; i++)            //由于插入排序使得数组改变,因此需要还原数组A
        A[i] = temp[i];
    Merge(A, B, n);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值