对于给定的二叉树,本题要求你按从上到下、从左到右的顺序输出其所有叶节点。
输入格式:
首先第一行给出一个正整数 N(≤10),为树中结点总数。树中的结点从 0 到 N−1 编号。随后 N 行,每行给出一个对应结点左右孩子的编号。如果某个孩子不存在,则在对应位置给出 “-”。编号间以 1 个空格分隔。
输出格式:
在一行中按规定顺序输出叶节点的编号。编号间以 1 个空格分隔,行首尾不得有多余空格。
输入样例:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
输出样例:
4 5 1
思路:
题意重点在于“每行给出一个对应结点左右孩子的编号”。
此语意为:0结点左孩子为1,没有右孩子。1结点没有左右孩子,2结点左孩子为0…输入没有3,则3不是左、右孩子,3为根。
二叉树
代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<vector>
#include<set>
using namespace std;
struct stu1{
char first;
char second;
}stu[10];
int main(){
int n;
cin>>n;
queue<int> q;
set<char> st;
for(int i=0;i<n;i++){
char a,b;
cin>>a>>b;
stu[i].first=a;
stu[i].second=b;
st.insert(a);
st.insert(b);
}
int root;
for(int i=0;i<n;i++){
if(st.find(i+'0')==st.end())
root=i;
}
q.push(root);
vector<int> x;
while(q.size()){
int m=q.front();
q.pop();
if(stu[m].first=='-'&&stu[m].second=='-')
x.push_back(m);
else{
if(stu[m].first!='-')
q.push(stu[m].first-'0');
if(stu[m].second!='-')
q.push(stu[m].second-'0');
}
}
int i;
for(i=0;i<x.size()-1;i++){
cout<<x[i]<<' ';
}
cout<<x[i];
}