浙大数据结构MOOC作业题目集2020——03-树3 Tree Traversals Again (25分)

该博客探讨了一种使用栈实现非递归中序遍历的方法,并通过给定的栈操作序列来构建一棵二叉树。文章通过示例解释了如何从给定的中序遍历序列推导出后序遍历序列。代码示例展示了如何根据前序和中序遍历构建二叉树并输出后序遍历序列。
摘要由CSDN通过智能技术生成

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路
栈中push进去的元素为前序遍历,pop出来的元素为中序遍历,求这颗二叉树的后续遍历
代码

#include<bits/stdc++.h>
using namespace std;
int flag=0;
stack<int> s;
vector<int>s1,s2,tree;//前序,中序 
void fun(int root,int start,int end){ 
	if(start>end) return;
	int i;
	for(i=start;i<=end;i++){
		if(s2[i]==s1[root]) break;
	}
	fun(root+1,start,i-1);//左子树 
	fun(root+i-start+1,i+1,end);//右子树 
	tree.push_back(s1[root]);
}
int main(){
	ios_base::sync_with_stdio(0);
	cin.tie(0);
	cout.tie(0);
	string op;
	int n,x;
	cin>>n;
	for(int i=0;i<2*n;i++){
		cin>>op;
		if(op=="Push"){
			cin>>x;
			s.push(x);
			s1.push_back(x);
		}
		else if(op=="Pop"){
			x=s.top();
			s2.push_back(x);
			s.pop();
		}
		
	} 
	fun(0,0,n-1);
	for(int i=0;i<n-1;i++)
	cout<<tree[i]<<" ";
	cout<<tree[n-1];
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值