【PAT】1113. Integer Set Partition (25)【字符串处理】

题目描述

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1 and A2​​ of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2 , respectively. You are supposed to make the partition so that ∣n​1−n2∣ is minimized first, and then ∣S​1−S2∣ is maximized.

翻译:给定有N(>1)个正整数的集合,你需要将它们分成两个不重合的集合A1和A2,分别有n1 和 n2个数字。让S1 和S2分别表示A1 和A2中的元素之和,你需要做出分类,使∣n​1−n2∣最小,∣S​1−S2∣最大。

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数N(2≤N≤10​5​),接下来一行包括N个正整数,用空格隔开。数据保证所有正整数和它们的和不超过 231

Output Specification:

For each case, print in a line two numbers: ∣n1−n2∣ and ∣S1−S2∣, separated by exactly one space.

翻译:对于每组输入数据,输出一行两个数字:∣n1−n2∣ 和 ∣S1−S2∣,中间用空格隔开。


Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555


Sample Output 1:

0 3611


Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85


Sample Output 2:

1 9359


解题思路

这道题数据设计的有些问题,直接调用sort试了一下,O(nlogn)的复杂度没有超时,就不想了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int N;
int num[100010];
int main(){
	scanf("%d",&N);
	for(int i=0;i<N;i++)scanf("%d",&num[i]);
	sort(num,num+N);
	int sum1=0,sum2=0;
	for(int i=0;i<N/2;i++){
		sum1+=num[i];
	}
	for(int i=N/2;i<N;i++){
		sum2+=num[i];
	}
	printf("%d %d\n",N%2,sum2-sum1);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值