【PAT】A1113 Integer Set Partition (25)

1113 Integer Set Partition (25 point(s))

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1 and A​2 of n​1 and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​ , respectively. You are supposed to make the partition so that ∣n​1​​ −n​2​​ ∣ is minimized first, and then ∣S​1​​ −S​2​​ ∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10
​5​​ ), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​^31​​ .

Output Specification:

For each case, print in a line two numbers: ∣n​1​​ −n​2​​ ∣ and ∣S​1​​ −S​2​​ ∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

Code

#include <iostream>
//#include <fstream>
#include <algorithm>
#include <vector>
using namespace std;
int main() {
    //ifstream cin("/home/my/Desktop/in.txt");
    int n, sum1 = 0, sum = 0;
    cin >> n;
    vector<int> vi(n);
    for(int i = 0; i < n; i++){
        cin >> vi[i];
        sum += vi[i];               // 求出所有数的和
    }
    sort(vi.begin(), vi.end());
    for(int i = 0; i < n / 2; i++)  sum1 += vi[i];      // 求出一半数的和
    printf("%d %d", n - n/2 - n/2, sum - sum1 - sum1);
    return 0;
}

Analysis

惊了,这样居然AC了。还在想用快排的思路。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值