ayit 第九周周赛 h题

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
#include<stdio.h>
int main()
{
    int r,k=0;
    scanf("%d",&r);
    while(r--)
    {
        int l,x,a=1,b=1,c,n=1,m,i;
        scanf("%d%d",&m,&x);
        l=x,k++;
        for(i=2; i<=m; i++)
        {
            if(l<0)
            {
                n=i;
                l=0;
            }
            scanf("%d",&c);
            l=l+c;
            if(l>x)
            {
                x=l;
                a=i;
                b=n;
            }
        }
        printf("Case %d:\n",k);
        printf("%d %d %d\n",x,b,a);
        if(r>0)
            printf("\n");
    }
    return 0;
}

题型  求最大连续子区间

题意   给你几个数求出最大的数和并输出从几到几(坐标)

思路   将当前子段的和与当前输入的数作比较,使子段和等于两者之间最大的数,当子段的和小于等于当前输入的数时,记录                 新的起点,并当新的最大子段和出现时,使用该新的起点

        这种题不能排序,排序就错了记得第一做时就想到了排序结果不对

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值