ayit第十四周周赛e题

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

 

 

#include<stdio.h>
#include<string.h>
#include<math.h>
char map[500][50];
int book[500][550];
int x,y,n,m,flag=0,t;
int dis[4][2]={0,1,1,0,0,-1,-1,0};
void dfs(int a,int b,int step)
{
    if(map[a][b]=='D'&&step==t)
    {
        flag=1;
        return ;
    }
    int i,t1,t2;
    if(step>=t)
        return ;
    t1=abs(x-a)+abs(y-b);
    t2=t-step-t1;
    if(t1%2!=(t-step)%2||flag||t2<0)
        return ;
    for(i=0; i<4; i++)
    {
        int tx,ty;
        tx=a+dis[i][0];
        ty=b+dis[i][1];
        if(!book[tx][ty]&&tx>=0&&ty>=0&&tx<n&&ty<m&&map[tx][ty]!='X')
        {
            book[tx][ty]=1;
            dfs(tx,ty,step+1);
            book[tx][ty]=0;
        }
    }

}
int main()
{
    while(~scanf("%d %d %d",&n,&m,&t)&&(n+m+t)!=0)
    {
        int a,b,i,j;
        flag=0;
        memset(book,0,sizeof(book));
        for(i=0; i<n; i++)
        {
            scanf("%s",map[i]);
            for(j=0; j<m; j++)
                if(map[i][j]=='S')
                {
                    a=i;
                    b=j;
                }

                else if(map[i][j]=='D')

                {
                    x=i;
                    y=j;
                }
        }
        book[a][b]=1;
        dfs(a,b,0);
        if(flag)
           printf("YES\n");
        else 
		printf("NO\n");
    }
    return 0;
}

题意 给定你起点S,和终点D,问你是否能在 T 时刻恰好到达终点D

思路   dfs和奇偶剪枝  在网上看了别人的思路 dog必须在第t秒到达门口。也就是需要走t-1步。设dog开始的位置为(sx,sy),目标位置为(ex,ey).如果abs(ex-x)+abs(ey-y)为偶数,则abs(ex-x)和abs(ey-y)奇偶性相同,所以需要走偶数步;当abs(ex-x)+abs(ey-y)为奇数时,则abs(ex-x)和abs(ey-y)奇偶性不同,到达目标位置就需要走奇数步。先判断奇偶性再搜索可以节省很多时间,不然的话容易超时。t-sum为到达目标位置还需要多少步。因为题目要求dog必须在第t秒到达门的位置,所以(t-step)和abs(ex-x)+abs(ey-y)的奇偶性必然相同。因此temp=(t-step)-abs(ex-x)+abs(ey-y)必然为偶数。
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值