【漫漫长征路】hihocoder #1082 然而沼跃鱼早就看穿了一切

【漫漫长征路D1】hihocoder #1082 然而沼跃鱼早就看穿了一切

描述

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出包含多行,为输入按照描述中变换的结果。

样例输入

The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB

样例输出

The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

AC的python代码

while True:
    try:
        t = input()
        lss = t.lower()
        tss = t
        c = list()
        if "marshtomp" not in lss:   #no need to process the string
            print(tss)
            continue
        if "marshtomp" in lss:
            ind = lss.index("marshtomp")
            ct = tss[ind : ind + 9]  
            lss = lss[ind + 9:]   #to avoid the repeated search
            c.append(ct)   # a list used to store the "marshtomp" in different case
            indtep = ind  # record the start index
        
        while( "marshtomp" in lss):
            ind = lss.index("marshtomp")
            lss = lss[ind + 9:]
            ind = ind + indtep + 9
            ct = tss[ind : ind + 9]
            indtep = ind
            c.append(ct)
            
        for st in c:
            tss = tss.replace(st, "fjxmlhx")
        print(tss)
    except EOFError:
        break

注意事项

  1. 多输入的格式
while True:
    try:
    
    except EOFError:
        break
  1. str.replace()会将所有的old str替换为new str,所以不可用于lss。
tss = tss.replace(st, "fjxmlhx")
  1. 中间那么长一段是为了将不同case的marshtomp读出,目前只完成了AC,可能有较大改进空间,有思路以后可能会进行更新。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值