题目来源:AcWing 829. 模拟队列
一、题目描述
实现一个队列,队列初始为空,支持四种操作:
push x
– 向队尾插入一个数 x x x;pop
– 从队头弹出一个数;empty
– 判断队列是否为空;query
– 查询队头元素。
现在要对队列进行 M M M 个操作,其中的每个操作 3 3 3 和操作 4 4 4 都要输出相应的结果。
输入格式
第一行包含整数
M
M
M,表示操作次数。
接下来
M
M
M 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示队头元素的值。
数据范围
1
≤
M
≤
100000
,
1≤M≤100000,
1≤M≤100000,
1
≤
x
≤
1
0
9
,
1≤x≤10^9,
1≤x≤109,
所有操作保证合法。
输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4
二、模拟队列
队列是一种先入先出的数据结构。
1. 队列定义
const int N = 1e5 + 10;
// 在队尾插入元素,在队头弹出元素
int q[N], hh, tt = -1;
2. 插入操作
q[++tt] = x;
3. 出队操作
hh++;
4. 判空操作
// 判断是否为空
if (hh <= tt) 非空;
else 空;
5. 取出队首队尾元素
q[hh], q[tt];
三、代码
#include <iostream>
using namespace std;
const int N = 1e5 + 10;
int q[N], hh, tt = -1;
int n;
int main()
{
cin >> n;
string op;
while (n--)
{
cin >> op;
if (op == "push")
{
int x;
cin >> x;
q[++tt] = x;
}
else if (op == "pop") hh++;
else if (op == "empty")
{
if (hh <= tt) puts("NO");
else puts("YES");
}
else cout << q[hh] << endl;
}
return 0;
}