1003 Emergency——dijkstra

题目描述

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​​ , c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C​2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题目分析

题目的大意是,给一个图,每两个顶点必存在一条路径,让你求最短路径的数量并且求这些路径中点权最大为多少(及路径上所有点救援队数量的总和)。
边权为正,求最短路,很快便可以想到dijkstra算法,然后是记录最短路路径问题,由于这边最短可能有多种情况,所以选择用线性表来记录,然后通过记录的路径回溯来求最短路径数和最大点权,可以使用dfs来回溯遍历。

dijkstra

dijkstra算法有朴素版和堆优化版,这题告诉我们N(≤500),没有具体说明M的范围,无法判断是稠密图还是稀疏图,不过N范围很小,问题不大,直接用堆优化版来做。

#include <queue>
#include <cstdio>
#include <cstring> 
#include <iostream>
using namespace std;

typedef pair <int, int> P;
const int N = 510;

typedef struct{
	int to, cost; 
}E;

int n, m, c1, c2;
int rescue[N], dist[N];
vector <int> path[N];
vector <E> maps[N];
bool vis[N];

void Dijkstra()
{
	memset(dist, 0x3f, sizeof dist);
	priority_queue <P, vector<P>, greater<P> > pq;
	dist[c1] = 0;
	pq.push({0, c1});
	
	while (pq.size())
	{
		int e = pq.top().second;
		pq.pop();
		
		if (vis[e]) continue;
		vis[e] = true;
		
		for (int i = 0; i < maps[e].size(); i ++ )
		{
			int a = maps[e][i].to, w = maps[e][i].cost;
			if (dist[a] > dist[e] + w)
			{
				dist[a] = dist[e] + w;
				path[a].clear();
				path[a].push_back(e);
				pq.push({dist[a], a});
			}
			else if (dist[a] == dist[e] + w)
				path[a].push_back(e);
		}
	}
}

int pathCnt, maxPath;
void dfs(int i, int nowPath)
{
	if (i == c1)
	{
		pathCnt ++;
		maxPath = max(maxPath, nowPath);
		return;
	}
	
	for (int j = 0; j < path[i].size(); j ++ ) dfs(path[i][j], nowPath + rescue[i]);
}

int main()
{
	cin >> n >> m >> c1 >> c2;
	for (int i = 0; i < n; i ++ ) scanf("%d", &rescue[i]);
	while (m --)
	{
		int a, b, w;
		scanf("%d%d%d", &a, &b, &w);
		maps[a].push_back(E{b, w});
		maps[b].push_back(E{a, w});
	}
	
	Dijkstra();
	dfs(c2, rescue[c1]);
	cout << pathCnt << " " << maxPath;
	 
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值