Buried memory

Buried memory


来源:HDU - 3007


题目描述:

Each person had do something foolish along with his or her growth.But,when he or she did this that time,they could not predict that this thing is a mistake and they will want this thing would rather not happened.
The world king Sconbin is not the exception.One day,Sconbin was sleeping,then swakened by one nightmare.It turned out that his love letters to Dufein were made public in his dream.These foolish letters might ruin his throne.Sconbin decided to destroy the letters by the military exercises’s opportunity.The missile is the best weapon.Considered the execution of the missile,Sconbin chose to use one missile with the minimum destruction.
Sconbin had writen N letters to Dufein, she buried these letters on different places.Sconbin got the places by difficult,he wants to know where is the best place launch the missile,and the smallest radius of the burst area. Let’s help Sconbin to get the award.


输入格式:

There are many test cases.Each case consists of a positive integer N(N<500,V,our great king might be a considerate lover) on a line followed by N lines giving the coordinates of N letters.Each coordinates have two numbers,x coordinate and y coordinate.N=0 is the end of the input file.


输出格式:

For each case,there should be a single line in the output,containing three numbers,the first and second are x and y coordinates of the missile to launch,the third is the smallest radius the missile need to destroy all N letters.All output numbers are rounded to the second digit after the decimal point.


输入样例:

3
1.00 1.00
2.00 2.00
3.00 3.00
0

输出样例:

2.00 2.00 1.41

思路:

典型的最小覆盖圆问题,用求解最小覆盖圆问题的算法解决即可。


AC代码:

#include <bits/stdc++.h>

using namespace std;

typedef long long LL;
typedef unsigned long long ULL;

const int INF = 0x3f3f3f3f;
const int EPS = 1e-8;

void __init__ ()
{
    // freopen("input.txt", "r", stdin);
    // freopen("output.txt", "w", stdout);
    ios::sync_with_stdio(false);
    cin.tie(NULL);
    cout.tie(NULL);
}

struct Point
{
    double x;
    double y;
};

int sgn (double x)
{
    if (fabs(x) < EPS) return 0;
    return x > 0 ? 1 : -1;
}

double distance (Point a, Point b)
{
    return hypot(a.x - b.x, a.y - b.y);
}

Point circle_center (Point a, Point b, Point c)
{
    Point center;
    double A1 = 2 * (b.x - a.x), B1 = 2 * (b.y - a.y), C1 = b.x * b.x + b.y * b.y - a.x * a.x - a.y * a.y;
    double A2 = 2 * (c.x - b.x), B2 = 2 * (c.y - b.y), C2 = c.x * c.x + c.y * c.y - b.x * b.x - b.y * b.y;
    center.x = (C1 * B2 - C2 * B1) / (A1 * B2 - A2 * B1);
    center.y = (C1 * A2 - C2 * A1) / (B1 * A2 - A1 * B2);
    return center;
}

void minus_cover_circle (vector<Point> p, Point& c, double& r)
{
    random_shuffle(p.begin(), p.end());
    c = p[0];
    r = 0;
    for (int i = 1; i < p.size(); i++)
    {
        if (sgn(distance(p[i], c) - r) > 0)
        {
            c = p[i];
            r = 0;
            for (int j = 0; j < i; j++)
            {
                if (sgn(distance(p[j], c) - r) > 0)
                {
                    c.x = (p[i].x + p[j].x) / 2;
                    c.y = (p[i].y + p[j].y) / 2;
                    r = distance(c, p[j]);
                    for (int k = 0; k < j; k++)
                    {
                        if (sgn(distance(p[k], c) - r) > 0)
                        {
                            c = circle_center(p[i], p[j], p[k]);
                            r = distance(c, p[k]);
                        }
                    }
                }
            }
        }
    }
}

vector<Point> p;

int main ()
{

    __init__();

    int n;
    Point c;
    double r;
    while (cin >> n && n)
    {
        p.resize(n);
        for (int i = 0; i < n; i++) cin >> p[i].x >> p[i].y;
        minus_cover_circle(p, c, r);
        cout << fixed << setprecision(2) << c.x << " " << c.y << " " << r << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值