Buried memory 简单几何之最小圆覆盖问题

Each person had do something foolish along with his or her growth.But,when he or she did this that time,they could not predict that this thing is a mistake and they will want this thing would rather not happened. 
The world king Sconbin is not the exception.One day,Sconbin was sleeping,then swakened by one nightmare.It turned out that his love letters to Dufein were made public in his dream.These foolish letters might ruin his throne.Sconbin decided to destroy the letters by the military exercises's opportunity.The missile is the best weapon.Considered the execution of the missile,Sconbin chose to use one missile with the minimum destruction. 
Sconbin had writen N letters to Dufein, she buried these letters on different places.Sconbin got the places by difficult,he wants to know where is the best place launch the missile,and the smallest radius of the burst area. Let's help Sconbin to get the award.
Input
There are many test cases.Each case consists of a positive integer N(N<500,^V^,our great king might be a considerate lover) on a line followed by N lines giving the coordinates of N letters.Each coordinates have two numbers,x coordinate and y coordinate.N=0 is the end of the input file.
Output
For each case,there should be a single line in the output,containing three numbers,the first and second are x and y coordinates of the missile to launch,the third is the smallest radius the missile need to destroy all N letters.All output numbers are rounded to the second digit after the decimal point. 
Sample Input
3
1.00 1.00
2.00 2.00
3.00 3.00
0
Sample Output

2.00 2.00 1.41


题意,给你一些点,然后让你求出能全部覆盖这些点的最小圆

直接最小圆覆盖算法      http://blog.csdn.net/tianyuhang123/article/details/53761400

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 100010
using namespace std;
struct node
{
    double x,y;
} b[N];
node O;
double R;
double sqr(double x)
{
    return x*x;
}
double dis(node x,node y)
{
    return sqrt(sqr(x.x-y.x)+sqr(x.y-y.y));
}
bool incircle(node x)
{
    if(dis(O,x)<=R) return true;
    return false;
}
node solve(double a,double b,double c,double d,double e,double f)
{
    double y=(f*a-c*d)/(b*d-e*a);
    double x=(f*b-c*e)/(a*e-b*d);
    return (node)
    {
        x,y
    };
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int i,j,k;
        for(i=1; i<=n; i++)
            scanf("%lf%lf",&b[i].x,&b[i].y);
        R=0;
        for(i=1; i<=n; i++)
            if(!incircle(b[i]))
            {
                O.x=b[i].x;
                O.y=b[i].y;
                R=0;
                for(j=1; j<i; j++)
                    if(!incircle(b[j]))
                    {
                        O.x=(b[i].x+b[j].x)/2;
                        O.y=(b[i].y+b[j].y)/2;
                        R=dis(O,b[i]);
                        for(k=1; k<j; k++)
                            if(!incircle(b[k]))
                            {
                                O=solve(
                                      b[i].x-b[j].x,b[i].y-b[j].y,(sqr(b[j].x)+sqr(b[j].y)-sqr(b[i].x)-sqr(b[i].y))/2,
                                      b[i].x-b[k].x,b[i].y-b[k].y,(sqr(b[k].x)+sqr(b[k].y)-sqr(b[i].x)-sqr(b[i].y))/2
                                  );
                                R=dis(b[i],O);
                            }
                    }
            }
        printf("%.2lf %.2lf %.2lf\n",O.x,O.y,R);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值