POJ2960 S-Nim
Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
The players take turns chosing a heap and removing a positive number of beads from it.
The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they
recently learned an easy way to always be able to find the best move:
Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
If the xor-sum is 0, too bad, you will lose.
Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
The player that takes the last bead wins.
After the winning player’s last move the xor-sum will be 0.
The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases.
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a ‘W’.If the described position is a losing position print an ‘L’.
Print a newline after each test case.
Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
Sample Output
LWW
WWL
Source
Svenskt Mästerskap i Programmering/Norgesmesterskapet 2004
题意: 多组输入,告诉你有k种可以取的选择,当k==0时退出。再给你m组数据,根据每组数据判断先手必胜,若必胜则这个Case的res加上W否则加上L,当m组数据读完时输出res。(是sg模板题,按套路来就不会出错了)
思路: 因为可以取的选择是人为设定好的,再根据题意的理解我们可以判断出这个是利用SG函数求解。一个游戏的异或值为0则后手必胜,我们可以用SG函数求出每一堆的异或值然后将这些异或值再一次异或,得到的就是这几堆的异或结果,我们只要判断这个值是否为0就好了。
#include<list>
#include<string.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<vector>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e4 + 10;
const int inf = 0x3f3f3f3f;
const int Base =131;
const ll INF = 1ll << 62;
//const double PI = acos(-1);
const double eps = 1e-7;
const int mod = 1e9+7;
#define speed {ios::sync_with_stdio(false);cin.tie(0);cout.tie(0); }
int f[110],sg[maxn],Hash[maxn],k;
//f[]是用来存储可以拿的个数
//sg[]用来存sg函数值
//Hash[]用来判断是否出现过
void getSG()
{
int cnt=1;//可以避免重复初始化Hash
memset(Hash,0,sizeof Hash);
for(int i=1;i<maxn;i++)
{
for(int j=0;i>=f[j]&&j<k;j++)
Hash[sg[i-f[j]]]=cnt;//将i的后继状态做上标记
for(int j=0;j<maxn;j++)//取集合中没有出现过的最小非负整数
{
if(Hash[j]!=cnt)
{
sg[i]=j;
break;
}
}
cnt++;
}
}
int main()
{
while(~scanf("%d",&k),k)
{
memset(sg,0,sizeof sg);
for(int i=0;i<k;i++)scanf("%d",&f[i]);
sort(f,f+k);//一定要进行排序
getSG();
int m;
string res;//储存结果
scanf("%d",&m);
for(int i=0;i<m;i++)
{
int x,ans=0;
scanf("%d",&x);
for(int j=0;j<x;j++)
{
int u;
scanf("%d",&u);
ans^=sg[u];
}
if(!ans)res+='L';
else res+='W';
}
cout<<res<<endl;
res.clear();
}
system("pause");
return 0;
}