POJ2635The Embarrassed Cryptographer(大数除法+素数筛)

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss’ key.
Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
Output

For each number K, if one of its factors are strictly less than the required L, your program should output “BAD p”, where p is the smallest factor in K. Otherwise, it should output “GOOD”. Cases should be separated by a line-break.
Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0
Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31
Source

Nordic 2005

题意: 多组输入s与n,两个都为0时退出,当存在比n小的数m(1除外)使得s%m==0输出BAD与m,否则输出GOOD。

思路: 先使用素数筛进行打表,然后用字符串对s进行模拟并进行除法,但是模拟除法时应一次性多取几个,一个一个取会超时。

#include<string.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e6+10;
const int inf = 0x3f3f3f3f;
const int Base =131;
const ll INF = 1ll << 62;
//const double PI = acos(-1);
const double eps = 1e-7;
const int mod = 1e9+7;
#define mem(a,b) memset(a,b,sizeof(a))
#define speed {ios::sync_with_stdio(false);cin.tie(0);cout.tie(0); }

/*void exgcd(int a,int b,int &x,int &y)
{
	if(b==0)
	{
		x=1,y=0;
		return;
	}
	exgcd(b,a%b,x,y);
	int tmp=x;
	x=y;
	y=tmp-(a/b)*y;
}

int mod_inversse(int a,int m)
{
	int x,y;
	exgcd(a,m,x,y);
	return (m+x%m)%m;
}

int euler[maxn];
void Euler()
{
     for(int i=0;i<maxn;i++)euler[i]=i;
     for(int i=2;i<maxn;i++)  
        if(euler[i]==i)  
           for(int j=i;j<maxn;j+=i)  
              euler[j]=euler[j]/i*(i-1);
}*/

vector<int>save;
int isPrime[maxn];//对1e6+10的数据进行打表判断素数
inline void Judge()
{
    mem(isPrime,-1);//-1说明是素数
    isPrime[1]=0;
	for(int i=2;i<=maxn;i++)
	{
		if(isPrime[i])
		{
			save.push_back(i);//存入素数
			for(int j=2;j<=maxn&& i*j<=maxn;j++)
				isPrime[i*j]=0;
		}	
	}
}

int main()
{
	Judge();
	speed;
	string s;
	int n;
	while(cin>>s>>n)
	{
		if(s[0]=='0'&&n==0)break;
		for(int i=0;i<save.size();i++)
		{
			if(save[i]>=n)//等于的时候也要输出GOOD
			{
				printf("GOOD\n");
				break;
			}
			int leave=0;//余数
			
			for(int j=0;j<=s.size();j+=3)//取3个数出来进行取余,如果一个一个取会TLE
			{
				int tmp=leave;
				for(int k=j;k<j+3&&k<s.size();k++)
					tmp=tmp*10+(s[k]-'0');
				leave=tmp%save[i];
			}

			if(!leave)//如果可以整除即余数为0
			{
				printf("BAD %d\n",save[i]);
				break;
			}
		}
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值