POJ-3267 字符串dp

POJ-3267 The Cow Lexicon 字符串dp

题面:

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a’…‘z’. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said “browndcodw”. As it turns out, the intended message was “browncow” and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a’…‘z’) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3…W+2: The cows’ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

题意:

给一个字符串,和由不同的单词组成的一套字典。该字符串是由几个单词组成,但单词的字母之间、单词与单词之间会参杂其它字母,找出最少删除多少字母,使得字符串只由字典中的单词组成。

题解:

dp[i] : 前 i 个字母只由字典单词组成时,最少删除的字母数

状态转移方程: d p [ i ] = m i n ( d p [ i ] , d p [ p ] + ( i − p ) − l e n ) ; dp[i] = min( dp[i] , dp[p] + (i-p) - len ); dp[i]=min(dp[i],dp[p]+(ip)len);

如:文本串:s = akppt

​ 模式串:s1 = kt

​ len:模式串的长度

​ i :文本串遍历的位置

​ 遍历文本串,若s[i] = s1[len-1] , 向前匹配,若匹配成功, p:文本串匹配成功的前一位

AC代码

#include <iostream>
#include <string.h>
#define ll long long
using namespace std;

int m,n;
char s[1000];
int dp[350];     //前 i个字符最少删除的个数  
char s1[650][350];

int main(){
	while(cin>>m>>n){
	cin>>s+1;
	for(int i=0;i<m;i++) cin>>s1[i];
	for(int i=1;i<=n;i++){  //遍历s 
		dp[i] = dp[i-1] + 1;
		for(int j=0;j<m;j++){  //遍历字典里的所有词  
			int len = strlen(s1[j]);
			//当单词末位最后一个字母匹配成功  
			if(s1[j][len-1] == s[i] && i >= len){
				int p=i,q=len-1,flag = 0;   //双指针 
				while(p>=0){
					if(q == -1){
						flag = 1;break;
					}
					if(s[p] == s1[j][q]){
						p--;q--;
					}
					else p--;
				}
				
				//此时 p指向文本串的单词前一位 
				if(flag){
					dp[i] = min(dp[i], dp[p]+(i-p)-len);

				} 
			}
		}

	}
	cout<<dp[n]<<endl;
}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值