werewolf

werewolf

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: “Player #2 is a werewolf.”;
  • player #2 said: “Player #3 is a human.”;
  • player #3 said: “Player #4 is a werewolf.”;
  • player #4 said: “Player #5 is a human.”; and
  • player #5 said: “Player #4 is a human.”.

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. Can you point out the werewolves?

Now you are asked to solve a harder vertion of this problem: given that there were N players, with M werewolves among them, at least one but not all the werewolves were lying, and there were exactly L liers. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integer N (5 ≤ N ≤ 100), M and L (2 ≤ M,L < N). Then N lines follow and the i-th line gives the statement of the i-th player (1 ≤ i ≤ N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in descending order the indices of the M werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the largest solution sequence – that is, for two sequences A = { a[1], …, a[M] } and B = { b[1], …, b[M] }, if there exists 0 ≤ k < M such that a[i] = b[i] (i ≤ k) and a[k+1]>b[k+1], then A is said to be larger than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5 2 2
-2
+3
-4
+5
+4

Sample Output 1:

4 1

Sample Input 2:

6 2 3
-2
+3
-4
+5
+4
-3

Sample Output 2:

6 4

Sample Input 3:

6 2 5
-2
+3
-4
+5
+4
+6

Sample Output 3:

No Solution

solution

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int player, werewolf, liar;
//answer记录当前最优的答案,当dfs结束后就是真正的答案了
vector<int> answer;
//进行dfs的函数,lie中撒谎的人为-1没撒谎的人为1,wolf中判断为狼人者为-1人类为1,state中记录了所有人的发言,i为当前到哪个人发言了
void judge(vector<int> lie, vector<int> wolf, vector<int>& state, int i);
//判据1
bool judgement1(int i, vector<int>& lie, vector<int>& wolf);
//判据2
bool judgement2(vector<int>& lie, vector<int>& wolf);
bool judgement3(vector<int>& wolf, int statement, int sign);
void compare(vector<int>& candidate);
void copy(vector<int>& candidate);
bool complete(vector<int> candidate, vector<int>& lie, int i, vector<int> blank, int num);

int main(void)
{
	cin >> player >> werewolf >> liar;
	vector<int> lie(player + 1, 0), wolf(player + 1, 0), state(player + 1, 0);
	int i, num;
	for (i = 0; i <= player; i++) {
		answer.push_back(0);
	}
	for (i = 1; i <= player; i++) {
		cin >> state[i];
	}
	judge(lie, wolf, state, 0);
	if (answer[0] == 0) {
		cout << "No Solution";
	}
	else if (answer[0] == 1) {
		for (i = player, num = 0; i >= 1; i--) {
			if (answer[i] == -1) {
				num++;
				cout << i;
				if (num == werewolf) {
					cout << endl;
				}
				else {
					cout << ' ';
				}
			}
		}
	}
	return 0;
}

void judge(vector<int> lie, vector<int> wolf, vector<int>& state, int i) {
	bool flag;
	int statement, backup, sign;
	flag = judgement1(i, lie, wolf);
	if (flag == false) {
		return;
	}
	if (i == player) {
		flag = judgement2(lie, wolf);
		return;
	}
	i++;
	statement = state[i];
	if (statement < 0) {
		sign = -1;
		statement = -statement;
	}
	else if (statement > 0) {
		sign = 1;
	}
	else {
		cout << "Wrong in judge!!!" << endl;
	}
	backup = wolf[statement];
	//telling truth
	flag = judgement3(wolf, statement, sign);
	if (flag == true) {
		lie[i] = 1;
		judge(lie, wolf, state, i);
	}
	wolf[statement] = backup;
	//lying
	flag = judgement3(wolf, statement, -sign);
	if (flag == true) {
		lie[i] = -1;
		judge(lie, wolf, state, i);
	}
}

bool judgement1(int i, vector<int>& lie, vector<int>& wolf) {
	int num_lie, num_wolf, left, pos_wolf;
	left = player - i;
	num_lie = count(lie.begin(), lie.end(), -1);
	num_wolf = count(wolf.begin(), wolf.end(), -1);
	pos_wolf = num_wolf + count(wolf.begin(), wolf.end(), 0) - 1;
	if (left < werewolf - pos_wolf || left < liar - num_lie || num_wolf > werewolf || num_lie > liar) {
		return false;
	}
	return true;
}

bool judgement2(vector<int>& lie, vector<int>& wolf) {
	bool every, exist;
	every = exist = false;
	int i, num = 0, c_w, l_w, j;
	vector<int> blank;
	for (i = 1; i <= player; i++) {
		if (wolf[i] == 0) {
			num++;
			blank.push_back(i);
		}
	}
	c_w = count(wolf.begin(), wolf.end(), -1);
	l_w = werewolf - c_w;
	if (l_w > num) {
		cout << "Wrong in judgement2!!!" << endl;
	}
	complete(wolf, lie, l_w, blank, num);
	return true;
}

bool judgement3(vector<int>& wolf, int statement, int sign) {
	if (wolf[statement] == 0) {
		wolf[statement] = sign;
		return true;
	}
	else if (wolf[statement] * sign < 0) {
		return false;
	}
	else
		return true;
}

void compare(vector<int>& candidate) {
	int i;
	bool change = false;
	if (answer[0] == 0) {
		copy(candidate);
		answer[0] = 1;
	}
	else if (answer[0] == 1) {
		for (i = player; i >= 1; i--) {
			if (answer[i] == 1 && candidate[i] == -1) {
				change = true;
				break;
			}
			else if (answer[i] == -1 && candidate[i] == 1) {
				break;
			}
		}
		if (change == true) {
			copy(candidate);
		}
	}
}

void copy(vector<int>& candidate) {
	int i;
	for (i = 1; i <= player; i++) {
		answer[i] = candidate[i];
	}
}

bool complete(vector<int> candidate, vector<int>& lie, int i, vector<int> blank, int num) {
	bool every, exist, flag;
	exist = every = false;
	int j, backup;
	if (i == 0) {
		for (j = 0; j < num; j++) {
			candidate[blank[j]] = 1;
		}
		num = 0;
	}
	if (i == num) {
		for (j = 0; j < i; j++) {
			candidate[blank[j]] = -1;
		}
		for (j = 1; j <= player; j++) {
			if (candidate[j] == -1) {
				if (lie[j] == -1) {
					exist = true;
				}
				else if (lie[j] == 1) {
					every = true;
				}
				else {
					cout << "Wrong in judgement2!!!1" << endl;
				}
			}
		}
		if (exist && every) {
			for (i = 1; i <= player; i++) {
				if (candidate[i] == 0) {
					cout << "Wrong in judgement2!!!2" << endl;
				}
			}
			compare(candidate);
			return true;
		}
		return false;
	}
	else {
		backup = blank[blank.size() - 1];
		blank.pop_back();
		candidate[backup] = -1;
		flag = complete(candidate, lie, i - 1, blank, num - 1);
		if (flag == true) {
			return true;
		}
		candidate[backup] = 1;
		flag = complete(candidate, lie, i, blank, num - 1);
		if (flag == true) {
			return true;
		}
		return false;
	}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值