7-7 计算高考状元 (30 分)
高考成绩已经公布,大家正在填报志愿。设计一个学生类student,四门学科成绩是其私有成员,分别是语文、数学、英语、综合。有个计算高考状元的函数是其友元函数,其形式是 student top(const student *p, int count) 。
以上类名和友元函数的形式,均须按照题目要求,不得修改。
输入是姓名 和 四科成绩,以0结束。 (不超过100个学生) 输出是状元的总分。
输入样例:
Alice 105 107 107 230
Bob 112 120 120 250
0
输出样例:
602
#include<iostream>
using namespace std;
class student{
private:
string name;
float chinese,math,english,complex;
public:
student(string str="",float a=0,float b=0,float c=0,float d=0):name(str),chinese(a),math(b),english(c),complex(d){};
friend student top(const student* p, int count);
void printScore(){
cout<<chinese+math+english+complex<<endl;
}
};
int main(){
string str;
float a,b,c,d;
student stu[101];
student topStu;
int i=0;
while(true){
cin>>str;
if(str=="0") break;
cin>>a>>b>>c>>d;
stu[i]=student(str,a,b,c,d);
i++;
}
//i--; You are wrong if you add this statement
topStu=top(stu,i);
topStu.printScore();
return 0;
}
student top(const student* p, int count) {//The first parameter can be used as the first address of the array.
student temp;
int sum=temp.chinese+temp.math+temp.english+temp.complex;
int sum1=0;
for(int i=0;i<count;i++){
sum1=p[i].chinese+p[i].math+p[i].english+p[i].complex;
if(sum<sum1){
sum=sum1;
temp=p[i];
}
}
return temp;
}