PTA-树的遍历

7-8 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2


思路:建树的时候维护一下树的深度,遍历树的时候维护一下同层的访问次序
Code:

#include<bits/stdc++.h>
#define bug(x) cout<<#x<<" = "<<x<<endl;
using namespace std;
typedef long long ll;
const int N = 1e4 + 10;
const int inf = 1e9;
int n;
int a[N],b[N];
struct Node {
	int data;
	int dep;
	Node *left,*right;
};
struct NODE {
	int id;
	int dep;
	int data;
};
Node* build(int x,int y,int z,int w,int dep) {
	if(x>y) return NULL;
	Node *tep;
	tep = new Node;
	int i=z;
	for(; i<=w; i++) if(b[i]==a[y]) break;
	int l1 = i-z;
	tep->data = a[y];
	tep->dep = dep;
	tep->left = build(x,x+l1-1,z,i-1,dep+1);
	tep->right = build(x+l1,y-1,i+1,w,dep+1);
	return tep;
}
vector<NODE> res;
int cnt = 0;
void work(Node *root) {
	if(root) {
		cnt++;
		res.push_back({cnt,root->dep,root->data});
		work(root->left);
		work(root->right);
	}
}
bool cmp(NODE a,NODE b) {
	if(a.dep==b.dep) return a.id<b.id;
	return a.dep < b.dep;
}
int main() {
	cin>>n;
	for(int i=1; i<=n; i++)	cin>>a[i];
	for(int i=1; i<=n; i++)	cin>>b[i];
	Node *root;
	root = new Node;
	root = build(1,n,1,n,1);
	work(root);
	sort(res.begin(),res.end(),cmp);
	for(int i=0; i<res.size(); i++) {
		if(i) cout<<" ";
		cout<<res[i].data;
	}
	return 0;
}

/*
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值