PTA A1031 输出图形helloworld

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

图像输出题目:

  • 控制输出法,一边输入一遍输出,走一步看一步.
  • 整体法,那就是把图先画好,然后再一次性都输出了。方法就是设置一个二维数组。想象一下把二维数组摊开在A4纸上,是不是密密麻麻的方格,在每一个方格中添入我要的东西,其它放个填入‘ ’空格, 最后输出的形状

 

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main() {
	char str[100];//输入代码
	char ans[40][40];//二维数组画图

	fgets(str, 100, stdin);//C11已经不用gets()

	int N = strlen(str) - 1;//fgets尾部包含回车字符,故长度为x-1

	//设限
	int n1, n2, n3;
	n1 = (N + 2) / 3;
	n3 = n1;
	n2 = N + 2 - n1 - n3;
	//

	for (int i = 1; i <= n1; i++) {
		for (int j = 1; j <= n2; j++) {
			ans[i][j] = ' ';//初始化二维数组--画白纸
		}
	}
	int pos = 0;

	//作图
	for (int i = 1; i <= n1; i++) {
		ans[i][1] = str[pos++];//第一列 
	}

	for (int j = 2; j <= n2; j++) {//最后一行
		ans[n1][j] = str[pos++];
	}

	for (int i = n3 - 1; i >= 1; i--) {//最后一列
		ans[i][n2] = str[pos++];
	}

	for (int i = 1; i <= n1; i++) {//一起输出
		for (int j = 1; j <= n2; j++) {
			printf("%c", ans[i][j]);
		}
		printf("\n");//按行输出 换行
	}
	return 0;

	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值