pat 甲级 A1008 Elevator

1008 Elevator

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题意:样例第一个数为要去的楼层个数,后面数是要去的顺序,上楼的话上一层要6秒,下楼下一层要4秒,不管是上楼还是下楼电梯都要在这个楼层等5秒;

思路:用to代表要去的楼层,now代表现在的楼层,to比now大就是上楼,比now小就是下楼,不管上楼还是下楼都要等5秒,从而得出总时间;

代码:

#include<iostream>
using namespace std;
int main(){
	int n,to,now=0,cost=0;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>to;
		to>now?cost+=(to-now)*6:cost+=(now-to)*4;
		cost+=5;
		now=to;
	}
	cout<<cost;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值