PAT 甲级 1024 Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353

题意:
给出一个数n(这个数可能是10^10位数的数,所以应该想到字符串存储),然后再给出另一个数m,该数为操作的次数,该操作为如果该数n正写和反写不一样,如123,321,就要进行相加操作,直到出现回文数,即像121,484这样正写反写都一样的数或者达到了操作次数,满足这两条中的一条都要输出该数,然后再输出找到回文数或者到达要求次数的操作数;

思路:

模拟加法,用头文件algorithm里面的reverse将字符串反转,再判断反转后字符串和原字符串是否相同,否则就进行反转字符串和原字符串相加,相加后相当于操作了一次,计数器加一,如果找打回文数或者到达操作数就退出循环;

大整数相加之模拟加法:

设置一个数作为储存这一位数的结果,num=(第一个数对应位的数)+(第二个数对应位的数)+后一位数运算的进位数;

该位数最后的值为:num%10

进位:jinwei=num/10;

代码:

#include<iostream>
#include<algorithm>
using namespace std;
string add(string s1,string s2){
	long long jinwei=0,yushu,num;
	string s;
	for(int i=s1.length()-1;i>=0;i--){
		num=(s1[i]-'0')+(s2[i]-'0')+jinwei;
		jinwei=num/10;
		yushu=num%10;
		s=to_string(yushu)+s; 
	}
	if(jinwei>0){
		s.insert(0,to_string(jinwei));
	} 
	return s;
}
int main(){
	string s1,s2;
	long long n,cnt=0;
	cin>>s1>>n;
	for(int i=0;i<n;i++){
	s2=s1;//s2是原值,s1是反转后的值;
	reverse(s1.begin(),s1.end());
	if(s1==s2){//判断是否为回文数; 
		cout<<s1<<"\n";
		break;
		}
	s1=add(s1,s2);//加一次算一次; 
	cnt++;
	} 
	if(cnt==n)cout<<s1<<"\n";
	cout<<cnt;
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值