PAT 甲级 1039 Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni​ (≤200) are given in a line. Then in the next line, Ni​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:

输出:11个学生,5门课程,接着下一行,课程编号是4,选这个课的有7个学生...最后一行输入要学生的名字,后面按这个顺序输出的课程数和所选课程;

输出:按顺序输出学生所选的课程数和所选的课程;

考点:

一、字符串哈希(字符串转换成整数)

公式:H(P)=X*range+Y;

1.字符串由大写字母A到Z组成

代码:
 

int getid(char s[],int len){
	int id;
	for(int i=0;i<len;i++){
		id=id*26+(s[i]-'A'); //将26进制转换成10进制,对应着唯一下标;
	}
	return id;
}

2.字符串由小写字母和大写字母组成

代码:

int getid(char s[],int len){
	int id;
	for(int i=0;i<len;i++){
		if(s[i]>='A'&&s[i]<='Z')//52进制转换成10进制; 
		id=id*52+(s[i]-'A'); 
		else 
		id=id*52+(s[i]-'A')+26; 
	}
	return id;
}

3.大写英文和数字(如ABB1)

int getid(char s[],int len){
	int id;
	for(int i=0;i<len-1;i++){
		id=id*26+(s[i]-'A'); //将26进制转换成10进制,对应着唯一下标;
	}
		id=id*10+(s[len-1]-'0');
	return id;
}

二、vector作二维数组和排列;

代码:
 

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=26*26*26*10+1;//三个字母和一个数字的排列,id的所有可能;
vector<int > student[maxn];//用vector因为要在 学生(字符串转换成整数)下标后面添加数值,二维数组; 
int getid(char s[]){//将学生的名字(字符串)转换成整数; 
	int id=0,i=0;
	for(i=0;i<3;i++){//已知学生名字由三个大写字母和一个数字组成; 
		id=id*26+(s[i]-'A');
	}
	id=id*10+(s[i]-'0');
	return id;
}
int main(){
	int n,m;
	char name[5];
	cin>>n>>m;//输出学生数和课程数;
	for(int i=0;i<m;i++){//对每一个课程进行处理; 
		int cid,snum;//课程编号和选这个课的学生数;
		cin>>cid>>snum;
		for(int j=0;j<snum;j++){
			cin>>name;
			int id=getid(name);
			student[id].push_back(cid);//把课程放到学生所在的下标的后面; 
		} 
	}
	for(int i=0;i<n;i++){
		cin>>name;
		int id=getid(name);
		sort(student[id].begin(),student[id].end());//课程序号需要从小到大排序; 
		cout<<name<<" "<<student[id].size();
		for(int j=0;j<student[id].size();j++){
			cout<<" "<<student[id][j];
			}
			cout<<"\n";
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值