A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the total sales from all the retailers.
Input Specification:
Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
Ki ID[1] ID[2] ... ID[Ki]
where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.
Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4
Code Size Limit16 KB
Time Limit250 ms
Memory Limit64 MB
题意:
有一个价格,在树上每过一层就要加价r/100, 然后到叶子结点也就是商贩,他们哪里有存货,要算如果把这些存货都买下来要多少钱。
样例分析:
10个结点,1.80为起始价,1.00就是每经过一个商家要加的价格
3 2 3 5//就是0号结点有3个孩子结点编号分别是2,3,5
...
0 9//0说明没有孩子,即叶子结点,此时9代表的就是存货量,也就是该叶子结点的权值
思路:这题就是对树进行深度优先搜索, 找出叶子结点的深度就知道要加多少次的价格了,最后再把总价算出来即可。
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
const int Maxn = 100010;
struct node {
int data;
vector<int > child;
} Node[Maxn];
int n, k, w, child;
double p, r,all;
void DFS(int nowNode, int depth) {
if(Node[nowNode].child.size() == 0) {
all += Node[nowNode].data * pow(1+r, depth);
}
for(int i = 0; i < Node[nowNode].child.size(); i++) {
DFS(Node[nowNode].child[i], depth+1);
}
}
int main() {
scanf("%d %lf %lf", &n, &p, &r);
r /= 100;
for(int i = 0; i < n; i++) {
scanf("%d", &k);
if(k == 0) {
scanf("%d", &w);
Node[i].data = w;
} else {
for(int j = 0; j < k; j++) {
scanf("%d", &child);
Node[i].child.push_back(child);
}
}
}
DFS(0, 0);
printf("%.1lf", p * all);
return 0;
}