POJ - 1852 Ants

问题描述:

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

输入说明:

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

输出说明:

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

SAMPLE INPUT:

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

SAMPLEOUTPUT:

4 8
38 207

思路:

题意是让我们求第一只蚂蚁落杆的时间以及最后一只蚂蚁落杆的时间,看似很复杂,要考虑两只蚂蚁相遇时的各种情况,其实不然,每只蚂蚁无论在什么与另外的蚂蚁相遇,掉下木棍的时间都只有两种,当前的位置a,以及根子长l-a。
那我们只要每输入一组数据,对这两个数据进行比较即可,很容易就能得到最大和最小值。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int T;
	scanf("%d",&T);//建议这样写,用cin交了一发tle
	while(T--)
	{
		int minmum=0,maxmum=0,len,n;
		scanf("%d%d",&len,&n);//建议这样写,用cin交了一发tle
		int a;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a);
			maxmum=max(maxmum,max(a,len-a));
			minmum=max(minmum,min(a,len-a));
		}
		printf("%d %d\n",minmum,maxmum);
	}
	return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值