POJ2182 Lost Cows(树状数组、二分、倍增)

Lost Cows

题目链接

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1…N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

  • Line 1: A single integer, N

  • Lines 2…N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

  • Lines 1…N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

方法一

平平无奇的一个二分+树状数组,时间复杂度 O ( n l o g 2 n ) O(nlog^2n) O(nlog2n)

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
int n,a[maxn],c[maxn];

void add(int x,int v){
    for(;x<maxn;x+=(x&-x))  c[x]+=v;
}

int ask(int x){
    int ret=0;
    for(;x;x-=(x&-x))   ret+=c[x];
    return ret;
}

int main(){
    scanf("%d",&n);
    for(int i=2;i<=n;i++)   scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)   add(i,1);
    for(int i=n;i>=1;i--){
        int l=1,r=n;
        while(l<r){
            int mid=(l+r)/2;
            int k=ask(mid);
            if(ask(mid)>=a[i]+1)  r=mid;
            else    l=mid+1;
        }
        a[i]=l,add(l,-1);
    }
    for(int i=1;i<=n;i++)   printf("%d\n",a[i]);
}

方法二

倍增+树状数组。倍增利用了树状数组本身的性质,它们的的组合更加契合。所以复杂度降为 O ( n l o g n ) O(nlogn) O(nlogn)
这个倍增会找一个符合条件的最大值,但是我们需要的是一个最小值,所以ans+c[k+qpow(2,j)]<a[i]+1,这里用了 < < <而不是 ≤ \leq ,就是寻找小于目标值的最大值,最后再 + 1 +1 +1,就得到了等于目标值的最小值。
总之是一个树状数组灵活应用的一个解法。

#include<cstdio>
#include<cmath>
using namespace std;
const int maxn=1e5+10;
int n,a[maxn],c[maxn];

int qpow(int a,int b){
    int ret=1;
    while(b){
        if(b&1) ret*=a;
        a*=a,b>>=1;
    }
    return ret;
}

void add(int x,int v){
    for(;x<maxn;x+=(x&-x))  c[x]+=v;
}

int main(){
    scanf("%d",&n);
    for(int i=2;i<=n;i++)   scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)   c[i]=i-(i-(i&-i));
    for(int i=n;i>=1;i--){
        int p=log2(n),k=0,ans=0;
        for(int j=p;j>=0;j--)
            if(k+qpow(2,j)<=n&&ans+c[k+qpow(2,j)]<a[i]+1)
                k+=qpow(2,j),ans+=c[k];
        a[i]=k+1,add(k+1,-1);
    }
    for(int i=1;i<=n;i++)   printf("%d\n",a[i]);
}

update(2022-3-26)

最近做天梯赛、笔试题的时候,几次都需要用到 “树状数组+二分/倍增”。翻了翻书,复习了 “树状数组+倍增” 的这个知识点,感觉又有新的收获吧。再贴一个今天写的代码,希望面试顺利、学业有成。

#include<bits/stdc++.h>
using namespace std;
constexpr int N=8010;
int n,a[N],c[N],sum[N];

void add(int x,int v){
	for(;x<N;x+=(x&-x)) c[x]+=v;
}

int main(){
	cin>>n;
	for(int i=1;i<N;i++) sum[i]=min(i,n);
	for(int i=1;i<N;i++) c[i]=sum[i]-sum[i-(i&-i)];
	for(int i=2;i<=n;i++) cin>>a[i],a[i]++;
	a[1]=1;
	for(int i=n;i>=1;i--){
		int p=0,ans=0;
		for(int j=(1<<12);j;j>>=1)
			if(p+j<N&&ans+c[p+j]<a[i]) ans+=c[p+j],p+=j;
        add(p+1,-1);
		a[i]=p+1;
	}
	for(int i=1;i<=n;i++) cout<<a[i]<<"\n";
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

m0_51864047

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值