N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.
Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.
Given this data, tell FJ the exact ordering of the cows.
Input
* Line 1: A single integer, N
* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
Output
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
Sample Input
5 1 2 1 0
Sample Output
2 4 5 3 1
AC的C++程序如下:
#include<iostream>
#include<cstdio>
using namespace std;
const int N=8000;
struct{
int l,r,len;
}tree[4*N+10];
int pre[N],ans[N];
void build(int left,int right,int u){
tree[u].l=left;
tree[u].r=right;
tree[u].len=right-left+1;
if(left==right){
return;
}
build(left,(left+right)>>1,u<<1);
build(((left+right)>>1)+1,right,(u<<1)+1);
}
int query(int u,int num){ //查询+维护,所求值为当前区间中左起第num个元素
tree[u].len--; //对访问到的区间维护,数量减一
if(tree[u].l==tree[u].r){
return tree[u].l;
}
//当左子区间个数不够时,则查询右子区间左起第num-tree[u<<1].len个元素
if(tree[u<<1].len<num){
return query((u<<1)+1,num-tree[u<<1].len);
}
//当左子区间个数足够时,则查询左子区间左起第num个元素
if(tree[u<<1].len>=num){
return query(u<<1,num);
}
}
int main(){
int n,i;
scanf("%d",&n);
pre[1]=0;
for(int i=2;i<=n;i++){
scanf("%d",&pre[i]);
}
build(1,n,1);
for(i=n;i>=1;i--){
ans[i]=query(1,pre[i]+1);
}
for(i=1;i<=n;i++){
printf("%d\n",ans[i]);
}
return 0;
}