HDOJ 1005 Number Sequence 超详细

HDOJ 1005 Number Sequence

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases.
 Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). 
Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

一个数字序列定义如下:f(1)= 1,f(2)= 1,f(n)=(A * f(n-1)B * f(n-2))mod 7.给定A ,B和n,计算f(n)的值。
这道题是有规律的因为是取余7也就是说是0~6七个数字再加上A,B两种数据那就是7*7=49一次轮回;

公式分析

#include<stdio.h>

int f(int, int, int);

int main(void)
{
    int na, nb, nn;
    while (scanf("%d %d %d", &na, &nb, &nn) && na != 0 && nb != 0 && nn != 0)
        printf("%d\n", f(na, nb, nn));
    return 0;
}

int f(int A, int B, int n)
{
    int i = 1;
    int one = 1, two = 1;
    n %= 49;//49一次轮回
    while (i <= n)
    {
        if (i == 1)
            one = 1;
        else if (i == 2)
            two = 1;
        else if (i % 2 == 1)        
            one = (A * two + B * one) % 7;
        else        
            two = (A * one + B * two) % 7;
        i++;
    }
    if (n % 2 == 1)
      return one;
    else            
      return two;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值