Stamps

Total Submission(s) : 21 Accepted Submission(s) : 9

Problem Description

Background Everybody hates Raymond. He’s the largest stamp collector
on planet earth and because of that he always makes fun of all the
others at the stamp collector parties. Fortunately everybody loves
Lucy, and she has a plan. She secretly asks her friends whether they
could lend her some stamps, so that she can embarrass Raymond by
showing an even larger collection than his. Problem Raymond is so
sure about his superiority that he always tells how many stamps he’ll
show. And since Lucy knows how many she owns, she knows how many more
she needs. She also knows how many friends would lend her some stamps
and how many each would lend. But she’d like to borrow from as few
friends as possible and if she needs too many then she’d rather not do
it at all. Can you tell her the minimum number of friends she needs to
borrow from?

Input

The first line contains the number of scenarios. Each scenario
describes one collectors party and its first line tells you how many
stamps (from 1 to 1000000) Lucy needs to borrow and how many friends
(from 1 to 1000) offer her some stamps. In a second line you’ll get
the number of stamps (from 1 to 10000) each of her friends is
offering.

Output

The output for every scenario begins with a line containing “Scenario
#i:”, where i is the number of the scenario starting at 1. Then print a single line with the minimum number of friends Lucy needs to borrow
stamps from. If it’s impossible even if she borrows everything from
everybody, write impossible. Terminate the output for the scenario
with a blank line.

Sample Input

3
100 6 13 17 42 9 23 57
99 6 13 17 42 9 23 57
1000 3 314 159 265

Sample Output

Scenario #1: 3

Scenario #2: 2

Scenario #3: impossible

题目大意:给定邮票数,要你从给定的人数手里借邮票,问需要借多少次才能满足

解题思路:先把n个人所拥有的的邮票数从大到小排好序,再用指定需要的邮票数去减当最后即所得数小于等于0,即可,在求得所需要的次数。

代码:

#include<stdio.h>
#include<stdlib.h>

int cmp(const void* a,const void* b)
{
    return *(int *)b-*(int *)a;
}

int main()
{
    int t,i,j,count=0;
    int stamp[1010];
    scanf("%d",&t);
    while(t--)
    {
        int n,f;
        count++;
        scanf("%d%d",&n,&f);
        for(i=0;i<f;i++)
        {
            scanf("%d",&stamp[i]);
        }
       qsort(stamp,f,sizeof(stamp[0]),cmp);
       for(j=0;j<f;j++)
       {
           n-=stamp[j];
           if(n<=0)
           {
               printf("Scenario #%d:\n",count);
               printf("%d\n\n",j+1);
               break;
           }
       }
       if(j==f)
       {
           printf("Scenario #%d:\n",count);
       printf("impossible\n\n");
       }

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值