Problem Description
A common typing error is to place the hands on the keyboard one row
to the right of the correct position. So “Q” is typed as “W” and “J”
is typed as “K” and so on. You are to decode a message typed in this
manner.
Input
Input consists of several lines of text. Each line may contain digits,
spaces, upper case letters (except Q, A, Z), or punctuation shown
above [except back-quote (`)]. Keys labelled with words [Tab, BackSp,
Control, etc.] are not represented in the input.
Output
You are to replace each letter or punctuation symbol by the one
immediately to its left on the QWERTY keyboard shown above. Spaces in
the input should be echoed in the output.
Sample Input
O S, GOMR YPFSU/
Sample Output
I AM FINE TODAY
题目大意:输入一段字符串,输出的内容为其在键盘左边的字母或字符。
代码:
#include<stdio.h>
#include<string.h>
char map[60]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
int main()
{
int i,j;
char a[60];
while(gets(a))
{
for(i=0;a[i];i++)
{
if(a[i]==' ')
{
printf(" ");
}
for(j=0;j<60;j++)
{
if(a[i]==map[j])
{
printf("%c",map[j-1]);
break;
}
}
}
printf("\n");
}
return 0;
}