WERTYU

Problem Description
在这里插入图片描述

A common typing error is to place the hands on the keyboard one row
to the right of the correct position. So “Q” is typed as “W” and “J”
is typed as “K” and so on. You are to decode a message typed in this
manner.

Input

Input consists of several lines of text. Each line may contain digits,
spaces, upper case letters (except Q, A, Z), or punctuation shown
above [except back-quote (`)]. Keys labelled with words [Tab, BackSp,
Control, etc.] are not represented in the input.

Output

You are to replace each letter or punctuation symbol by the one
immediately to its left on the QWERTY keyboard shown above. Spaces in
the input should be echoed in the output.

Sample Input

O S, GOMR YPFSU/

Sample Output

I AM FINE TODAY

题目大意:输入一段字符串,输出的内容为其在键盘左边的字母或字符。

代码:

#include<stdio.h>
#include<string.h>
char map[60]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
int main()
{
    int i,j;
    char a[60];
    while(gets(a))
    {
        for(i=0;a[i];i++)
        {
            if(a[i]==' ')
            {
                printf(" ");
            }
            for(j=0;j<60;j++)
            {
                if(a[i]==map[j])
                {
                    printf("%c",map[j-1]);
                    break;
                }
            }
        }
        printf("\n");
    }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值