1548 A strange lift

本文介绍了关于电梯操作的奇怪规则,其中每个楼层都有一个特定的步长。从某一楼层出发,要到达目标楼层,需要计算最少的按钮按下次数。通过BFS算法和剪枝策略解决这个问题。此外,文章还推荐了几款学习编程和提高编程技能的在线平台,包括LTPP在线开发平台、公益服务器、MYSQL服务和在线代码编辑器。
摘要由CSDN通过智能技术生成

题目详情:

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47831    Accepted Submission(s): 16738

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
Sample Input
5 1 5 3 3 1 2 5 0
 
Sample Output
3
 
Recommend
8600   |   We have carefully selected several similar problems for you:  1385 1142 1217 2066 2544 
题目大意:
坐电梯要去指定楼层,每次只能上和下,问最少需要按几次按钮。
解题思路:
BFS+剪枝
AC代码:
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
class Elevator{
    public:
        int floor;
        int times;
};
void BFS(vector<int>& l_num,int l_begin,int l_end){
    int min_times=0;
    vector<bool> visit(l_num.size(),1);
    queue<Elevator> l_q;//类队列
    Elevator cur,nex;
    cur.floor=l_begin;//初始化
    cur.times=0;//初始化
    l_q.push(cur);//入队
    while(!l_q.empty()){
        cur=l_q.front();//赋值
        l_q.pop();//出队
        visit[cur.floor]=0;//该楼层已经来过
        if(cur.floor==l_end){//如果当前楼层和目标楼层一样,结束循环
            cout<<cur.times<<endl;
            return;
        }
        nex.floor=cur.floor+l_num[cur.floor];
        nex.times=cur.times+1;//按的次数加一
        if(nex.floor<=l_end){//没超过目标楼层
            if(visit[nex.floor]){
                visit[nex.floor]=0;//标记来过该楼层
                l_q.push(nex);//入队
            }
        }
        nex.floor=cur.floor-l_num[cur.floor];//往楼下去
        nex.times=cur.times+1;//按的次数加一
        if(nex.floor>0){//下一个要去的楼层大于0
            if(visit[nex.floor]){
                visit[nex.floor]=0;//标记来过该楼层
                l_q.push(nex);//入队
            }
        }
    }
    cout<<"-1"<<endl;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n,begin,end;
    while(cin>>n>>begin>>end){
        vector<int> num(n+1,0);
        for(int i=1;i<=n;++i){
            cin>>num[i];
        }
        BFS(num,begin,end);
    }
    return 0;
}

推荐几款学习编程的网站

免费在线开发平台(LTPP在线开发平台 | LTPP宇宙文档

        探索编程世界的新天地,为学生和开发者精心打造的编程平台,现已盛大开启!这个平台汇集了近4000道精心设计的编程题目,覆盖了C、C++、JavaScript、TypeScript、Go、Rust、PHP、Java、Ruby、Python3以及C#等众多编程语言,为您的编程学习之旅提供了一个全面而丰富的实践环境。

        在这里,您不仅可以查看自己的代码记录,还能轻松地在云端保存和运行代码,让编程变得更加便捷。平台还提供了私聊和群聊功能,让您可以与同行们无障碍交流,分享文件,共同进步。不仅如此,您还可以通过阅读文章、参与问答板块和在线商店,进一步拓展您的知识边界。

        为了提升您的编程技能,平台还设有每日一题、精选题单以及激动人心的编程竞赛,这些都是备考编程考试的绝佳资源。更令人兴奋的是,您还可以自定义系统UI,选择视频或图片作为背景,打造一个完全个性化的编码环境,让您的编程之旅既有趣又充满挑战。

免费公益服务器(LTPP公益LINUX服务器分享 | LTPP宇宙文档

        作为开发者或学生,您是否为搭建和维护编程环境而困扰?现在,有一款免费的公共服务器,内置多种编程语言的编程环境,并且配备了在线版VS Code。让您可以随时随地在线写代码,无需复杂配置,专注于开发和学习。(PS:毕竟是免费公共的服务器,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费公益MYSQL(LTPP公益MYSQL分享 | LTPP宇宙文档

        作为一名开发者或学生,您是否常常为数据库环境的搭建而烦恼?是否因为预算有限而无法使用高性能的数据库服务?现在,有一款免费的MySQL服务器,专为开发者和学生量身打造,让你轻松无忧地进行开发和学习!内置在线phpmyadmin管理面板,方便用户查看数据。(PS:毕竟是免费公共的MYSQL,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费在线WEB代码编辑器(LTPP在线WEB编辑器 | LTPP宇宙文档

        无论你是开发者还是学生,编程环境的搭建和管理可能会占用你宝贵的时间和精力。现在,有一款强大的免费在线代码编辑器,支持多种编程语言,让您可以随时随地编写、调试和运行代码,提升编程效率,专注于创意和开发。

免费二维码生成器(LTPP二维码生成器 | LTPP宇宙文档

        无论是企业宣传、活动推广,还是个人信息分享,二维码都是一种快速、高效的信息传递方式。现在,有一款功能强大的二维码生成器,不仅易于使用,还具备多种便捷功能,帮助您更轻松地生成和管理二维码。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WA-自动机

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值