求最大公约数和最小公倍数

27 篇文章 0 订阅

最大公约数

#include<cstdio>
int gcd(int a, int b) {
	if (b == 0) return a;
	else return gcd(b, a % b);
}
int main() {
	int m, n;
	while (scanf_s("%d%d", &m, &n) != EOF) {
		printf("%d\n", gcd(m,n));
	}
	return 0;
}

最小公倍数
题目:2136 Problem A Least Common Multiple
题目描述
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
输入
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
输出
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
样例输入

2
2 3 5
3 4 6 12

样例输出

15
12
#include <iostream>
using namespace std;

int gcd(int a, int b) {
	if (b == 0) return a;
	else return gcd(b, a % b);
}
int main() {
	int n, m;
	cin >> n;
	while (n--) {
		cin >> m;
		int a, d;
		cin >> a;
		for (int j = 0;j < m - 1;j++) {
			int temp;
			cin >> temp;
			d = gcd(a, temp);
			if (d == 0) {
				a = 0;
				break;
			}
			a = a / d * temp;
        }
		cout << a;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值