【PAT】【dijkstra + dfs】1018 Public Bike Management (30 分)

题目链接:1018 Public Bike Management (30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

 // 易错点分析:

// 不符合最优子结构,必须要走完整条路径才能得到minsend 和 mintake

// 也就是说不可以用贪心解决,因为可能前段最优,但走完整条路经之后却比其它路径更劣

// 如果用了贪心的话求最优子结构递推的话,测试点7会被卡住过不去

 

// 解题思路:

// 这道题最好最方便的做法,是直接暴力dfs所有路径,因为数据不大

// 到目前为止题目数据的特点都是会卡有所偏颇走岔的思路和太劣的算法,而思路正确合理几乎不会超时

 

// 这里是用的dijkstra + dfs

// 即先求出最短的所有路径,然后dfs这些路径,比较哪条路径更优得到结果

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;


struct edge
{
    int v, w;
};

struct node
{
    int id, d;
    bool operator<(const node &r) const
    {
        return d > r.d;
    }
};

const int maxn = 5e2 + 5;
int a[maxn], dis[maxn];
vector<edge> mp[maxn];
priority_queue<node> q;

bool vis[maxn];
vector<int> path[maxn];
// 求最短路
void dijkstra(const int s, const int cmax)
{
    memset(dis, 0x3f, sizeof(dis));
    q.push((node){s, 0});
    dis[s] = 0;
    // 用了堆优化,这道题不用没影响
    while(!q.empty())
    {
        int id = q.top().id, d = q.top().d;
        q.pop();
        if(vis[id]) continue;
        vis[id] = true;
        for(int i = 0; i < mp[id].size(); i++)
        {
            int v = mp[id][i].v;
            if(vis[v]) continue;
            int w = mp[id][i].w;
            if(w + d < dis[v])
            {
                dis[v] = w + d;
                path[v].clear();
                path[v].push_back(id);
                q.push((node){v, dis[v]});
            }
            // 相同距离的路径也要保存下来
            else if(w + d == dis[v])
            {  
                path[v].push_back(id);
                q.push((node){v, dis[v]});
            }
        }
    }
}

// vector模拟,临时路径,和最终答案路径
vector<int> temp, ans;
// 初始化为最大
int ans_send = 1e8, ans_take = 1e8;
void dfs(int x, int cmax)
{
    // 加入路径
    temp.push_back(x);
    if(x == 0)
    {
        // 到达起点后,遍历这条路径得到send 和 take
        int ta(0), se(0);
        for(int i = temp.size() - 2; i >= 0; i--)
        {
            if(ta + a[temp[i]] < cmax)
            {
                se += cmax - ta - a[temp[i]];
                ta = 0;
            }
            else
            {
                ta = ta + a[temp[i]] - cmax;
            }
        }
        // 进行比较
        if(se < ans_send || (se == ans_send && ta < ans_take))
        {
            // vector可以直接整个数组赋给另一个vector
            ans = temp;
            ans_send = se;
            ans_take = ta;
        }
        return;
    }
    for(int i = 0; i < path[x].size(); i++)
    {
        dfs(path[x][i], cmax);
        // 尝试该路径之后要pop
        temp.pop_back();
    }
}

// 递归打印路径
void print_path()
{
    for(int i = ans.size() - 1; i >= 0; i--)
    {
        if(i == ans.size() - 1)
        printf("%d", ans[i]);
        else
        printf("->%d", ans[i]);
    }
}

int main()
{
    int cmax, n, tar, m;
    // 读入数据
    scanf("%d %d %d %d", &cmax, &n, &tar, &m);
    for(int i = 1; i <= n; i++)
    {
        scanf("%d", &a[i]);
    }
    // 建图
    for (int i = 0, u, v, w; i < m; i++)
    {
        scanf("%d %d %d", &u, &v, &w);
        mp[u].push_back((edge){v, w});
        mp[v].push_back((edge){u, w});
    }

    dijkstra(0, cmax);
    dfs(tar, cmax / 2);

    printf("%d ", ans_send);
    print_path();
    printf(" %d\n", ans_take);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值