PTA 1079 延迟的回文数 (20 分) C++实现

1079 延迟的回文数 (20 分)

给定一个 k+1 位的正整数 N,写成 ak ⋯a1​ a0​ 的形式,其中对所有 i 有 0 ≤ ai​ < 10 且 ak​ > 0。N 被称为一个回文数,当且仅当对所有 i 有 ai​ = ak−i​ 。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number

给定任意一个正整数,本题要求你找到其变出的那个回文数。

输入格式:

输入在一行中给出一个不超过1000位的正整数。

输出格式:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下:

A + B = C
其中 A 是原始的数字,B 是 A 的逆转数,C 是它们的和。A 从输入的整数开始。重复操作直到 C 在 10 步以内变成回文数,这时在一行中输出 C is a palindromic number.;或者如果 10 步都没能得到回文数,最后就在一行中输出 Not found in 10 iterations.。

输入样例 1:

97152
结尾无空行

输出样例 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
结尾无空行

输入样例 2:

196
结尾无空行

输出样例 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
结尾无空行

解题思路:

由于本题中的数最大可达1000位,因此如果在求和的时候没有特殊处理,而用了一般方法处理,则会过不了最后一个测试点
Tips:如果初始数就是回文数则就直接输出即可

代码示例(一般处理):

#define _CRT_SECURE_NO_DEPRECATE
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <vector>
#include <string>
#include <numeric>
#include <map>
using namespace std;

int main()
{
	int cnt = 0; //记录操作次数
	string s1, s2;
	cin >> s1;

	string temp = s1;
	reverse(temp.begin(), temp.end()); //反转函数reverse
	if (temp == s1)
	{
		cout << s1 << " is a palindromic number." << endl;
	}
	else
	{
		while (true)
		{
			if (cnt >= 10)
			{
				cout << "Not found in 10 iterations." << endl;
				break;
			}

			s2 = s1;
			reverse(s2.begin(), s2.end());
			
			//求和采用一般处理
			int num1 = stoi(s1); //直接转整形
			int num2 = stoi(s2);
			int sum = num1 + num2;

			cout << s1 << " + " << s2 << " = " << sum << endl;
			cnt++;

			string ans = to_string(sum);
			string temp = ans;
			reverse(temp.begin(), temp.end());

			if (temp == ans)
			{
				cout << ans << " is a palindromic number." << endl;
				break;
			}
			else
			{
				s1 = ans;
			}
		}
	}
	
}

运行结果:

在这里插入图片描述

代码示例(特殊处理):

#define _CRT_SECURE_NO_DEPRECATE
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <vector>
#include <string>
#include <numeric>
#include <map>
using namespace std;

//求和特殊处理函数,模拟加法的过程
string add(string s1, string s2) 
{
	string s = s1;
	int carry = 0;
	for (int i = s1.size() - 1; i >= 0; i--) //从个位开始相加
	{
		s[i] = ((s1[i] - '0') + (s2[i] - '0') + carry) % 10 + '0';
		carry = ((s1[i] - '0') + (s2[i] - '0')  + carry) / 10;
	}
	if (carry > 0) 
	{
		s = "1" + s;
	}
	return s;
}


int main()
{
	int cnt = 0;
	string s1, s2;
	cin >> s1;

	string temp = s1;
	reverse(temp.begin(), temp.end());
	if (temp == s1)
	{
		cout << s1 << " is a palindromic number." << endl;
	}
	else
	{
		while (true)
		{
			if (cnt >= 10)
			{
				cout << "Not found in 10 iterations." << endl;
				break;
			}

			s2 = s1;
			reverse(s2.begin(), s2.end());

			string sum = add(s1, s2); //求和特殊处理

			cout << s1 << " + " << s2 << " = " << sum << endl;
			cnt++;

			string ans = sum;
			string temp = ans;
			reverse(temp.begin(), temp.end());

			if (temp == ans)
			{
				cout << ans << " is a palindromic number." << endl;
				break;
			}
			else
			{
				s1 = ans;
			}
		}
	}
	
}

再次运行:

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Crazy.宥思

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值