PTA 1095 解码PAT准考证 (25 分) C++实现

1095 解码PAT准考证 (25 分)

PAT 准考证号由 4 部分组成:

第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
第 2~4 位是考场编号,范围从 101 到 999;
第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
最后 11~13 位是考生编号,范围从 000 到 999。
现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N( ≤ 10 ^ 4 )和 M( ≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
类型 为 2 的指令,按 人数 总分 的格式输出;
类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。 如果查询结果为空,则输出 NA

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
结尾无空行

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
结尾无空行

解题思路:

对于以及做到这一题的小伙伴 我认为不需要给太过于具体的思路了,模拟过程即可,这个代码超时了,解决方案就是能用 printf 和 scanf 就不用 cin 和 cout ,把代码尽量写的跟 c 一致,不要参杂过多的 C++ 风格

超时代码:

#include <iostream>
#include <vector>
#include <set>
#include <map>
#include <string>
#include <algorithm>

using namespace std;

struct st
{
	string id; //准考证号
	int grade; //成绩
};

struct stu
{
	int test_id; //考场编号
	int cnt; //学生总数
};

bool Sort1(st s1, st s2)
{
	if (s1.grade == s2.grade)
	{
		return s1.id < s2.id;
	}

	return s1.grade > s2.grade;
}

bool Sort2(stu s1, stu s2)
{
	if (s1.cnt == s2.cnt)
	{
		return s1.test_id < s2.test_id;
	}

	return s1.cnt > s2.cnt;
}

int main()
{
	int students, n; //学生数 操作数
	cin >> students >> n; 

	vector<st> res; //存结构体st的数组
	while (students--)
	{
		st temp;
		cin >> temp.id >> temp.grade;
		res.push_back(temp);
	}

	int count = 0; //数操作
	while (n--)
	{
		int type; //指令类型
		string key; //指令
		cin >> type >> key;

		count++;
		cout << "Case " << count << ": " << type << " " << key << endl;

		if (type == 1)
		{
			vector<st> ans;
			int flag = 0; //查询是否成功标志 为1表成功
			for (int i = 0; i < res.size(); i++)
			{
				string temp = res[i].id.substr(0, 1);
				if (temp == key)
				{
					flag = 1;
					ans.push_back(res[i]);
				}
			}

			if (flag == 0)
			{
				cout << "NA" << endl;
			}
			else
			{
				sort(ans.begin(), ans.end(), Sort1);
				for (int i = 0; i < ans.size(); i++)
				{
					cout << ans[i].id << " " << ans[i].grade << endl;
				}
			}
		}

		if (type == 2)
		{
			int sum = 0; //总成绩
			int cnt = 0; //数学生

			int flag = 0;
			for (int i = 0; i < res.size(); i++)
			{
				string temp = res[i].id.substr(1, 3);
				if (temp == key)
				{
					flag = 1;
					sum += res[i].grade;
					cnt++;
				}
			}

			if (flag == 0)
			{
				cout << "NA" << endl;
			}
			else
			{
				cout << cnt << " " << sum << endl;
			}
		}

		if (type == 3)
		{
			vector<int> ans(1005, 0);

			int flag = 0;
			for (int i = 0; i < res.size(); i++)
			{
				string temp1 = res[i].id.substr(4, 6);
				if (temp1 == key)
				{
					flag = 1;
					int index = stoi(res[i].id.substr(1, 3));
					ans[index]++;
				}
			}

			if (flag == 0)
			{
				cout << "NA" << endl;
			}
			else
			{
				vector<stu> real_ans;
				for (int i = 0; i < ans.size(); i++)
				{
					if (ans[i] != 0)
					{
						stu temp2;
						temp2.test_id = i;
						temp2.cnt = ans[i];
						real_ans.push_back(temp2);
					}
				}

				sort(real_ans.begin(), real_ans.end(), Sort2);
				for (int i = 0; i < real_ans.size(); i++)
				{
					cout << real_ans[i].test_id << " " << real_ans[i].cnt << endl;
				}
			}
		}
	}
}

运行结果:

在这里插入图片描述

优化代码(转载):

#include<iostream>
#include<algorithm>
using namespace std;
struct stu{
	string name;
	int score;
};
struct KC{
	string id;
	int num;
};
KC kc[1000];
bool cmp1(stu s1,stu s2){
	return (s1.score==s2.score )?s1.name <s2.name : s1.score>s2.score;
}
bool cmp2(KC a,KC b){
    return a.num != b.num ? a.num > b.num : a.id < b.id;	
}
stu st[10005];
stu temp[10005];
int main(){
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++){
		cin>>st[i].name;
		scanf("%d",&st[i].score);		
	}
	for(int ii=1;ii<=m;ii++){
		int a;
		scanf("%d",&a);
		if(a==1){
			char c;
			scanf(" %c",&c);
		printf("Case %d: %d %c\n",ii,a,c);
			int k=0;
			for(int i=0;i<n;i++){
				if(c==st[i].name[0]){
					temp[k++]=st[i];
				}
			}
			if(!k){
				printf("NA\n");
				continue;
			}
			sort(temp+0,temp+k,cmp1);
			for(int i=0;i<k;i++){
				printf("%s %d\n",temp[i].name.c_str(),temp[i].score);
			}
		}else if(a==2){
			string s;
			cin>>s;
			int k=0,sum=0;
			printf("Case %d: %d %s\n",ii,a,s.c_str());
			for(int i=0;i<n;i++){
				if(st[i].name.substr(1,3)==s){
					k++;
					sum+=st[i].score;
				}
			}if(k==0){
				printf("NA\n");
			}else{
				printf("%d %d\n",k,sum);
			}
		}else if(a==3){
			string day;
			cin>>day;
			printf("Case %d: %d %s\n",ii,a,day.c_str());
			int k=0;
			for(int i=0;i<n;i++){
				if(st[i].name.substr(4,6)==day){
					k++;
					int p=stoi(st[i].name.substr(1,3));
					kc[p].id=st[i].name.substr(1,3);
					kc[p].num++;
				}
			}
			if(k==0){
				printf("NA\n");
			}else{
				sort(kc+0,kc+1000,cmp2);
				for(int i=0;i<1000;i++){
					if(kc[i].num>0){
						printf("%s %d\n",kc[i].id.c_str(),kc[i].num);
                        kc[i].num=0;
					}else{
                        break;
                    }
				}
			}
			
		}
		
	}
	return 0;
}

运行结果:

在这里插入图片描述

转载链接:

https://blog.csdn.net/shiliang97/article/details/100592165

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Crazy.宥思

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值