Ordering Tasks / 拓扑排序

Ordering Tasks
 
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing  two integers, 1 n 100 and m . n is the number of tasks (numbered from 1 to
n ) and m is the number of direct precedence relations between tasks. After this, there will be
m lines with two integers i and j , representing the fact that task i must be executed before task j .
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3
 
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 1000;
int c[maxn];		//vis数组,-1为有回路, 0为正在访问, 1为已访问 
int topo[maxn], G[maxn][maxn], t, n , m;

bool dfs(int u) {
	c[u] = -1;		//访问标志
	for(int v = 0; v < n; v++) {
		if(G[u][v]) {
			if(c[v] < 0) return false;	//存在有向环,失败退出
			else if(!c[v] && !dfs(v)) return false; 
		}
	} 
	c[u] = 1; topo[--t] = u;
	return true;
}

bool toposort() {
	t = n;
	memset(c, 0, sizeof(c));
	for(int u = 0; u < n; u++) 
		if(!c[u]) if(!dfs(u)) return false;
	return true;
}

int main() {
	while(cin>>n>>m && n) {
		memset(G, 0, sizeof(G));
		for(int i = 0; i < m; i++) {
			int a, b; cin >> a >> b;
			G[a-1][b-1] = 1;
		}
		if(toposort()) {
			for(int i = 0; i < n; i++) {
				if(i != 0) putchar(' '); 
				cout << topo[i]+1 << ' ';
			}
			putchar('\n');
		} else {
			cout << "No" << '\n';
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yvonnae

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值