POJ-2453

As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.

For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".

Input

One integer per line, which is I (1 <= I <= 1000000).

A line containing a number "0" terminates input, and this line need not be processed.

Output

One integer per line, which is J.

Sample Input

1
2
3
4
78
0

Sample Output

2
4
5
8
83

整体思路:

        利用二进制加法原理实现,

        并运用贪心算法,一步一步进行。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[20]={0};
int b[20]={0};
int u,j,c;//u是用来记录某个数的二进制形式有多少位,j是用来记录需要加多少个1;c=u,保证每次加一都是从末尾加起
int w;//用来记录某二进制数有多少位1; 
void z2(int n){//将n转化为二进制形式 
	memset(a,0,sizeof(a));
	u=0;
	for(;;u++){
		a[u]=n%2;
		if(a[u]==1){
			w++;
		}
		n/=2;
		if(n==0){
			return;
		} 
	}
	
}
//void sum(){
//	int c=u;
//	for(;c>=0;c--){
//		if(a[c]==0){
//			if(c==u){
//				
//				break;
//			}
//			else if(c!=u){
//				
//				break;
//			} 
//			else if(c==0)
//			
//		}
//	}
//}
void sum1(int c){//递归末尾加一 模仿二进制加一 
	a[c]++;
	if(a[c]==2){
		a[c]=0;
		if(c!=0)
		sum1(c-1);
		else if(c==0){
			memset(b,0,sizeof(b));
			for(int i=0;i<u+1;i++){
				b[i]=a[i];
			}
			a[0]=1;
			a[1]=0;
			for(int i=2;i<u+2;i++){
				a[i]=b[i-1];
			}
			u++;
			c++;
		}
	}
}

int main(){
	for(;;){
		int n;
		cin>>n;
	//	for(n=1;n<101;n++){
		if(n==0){
			break;
		}
		w=0;
		z2(n);
		memset(b,0,sizeof(b));
		for(int i=0;i<u+1;i++){
			b[i]=a[i];
		} 
		for(int i=0;i<u+1;i++){
			a[i]=b[u-i];
		}
//			for(int i=0;i<u+1;i++){
//				cout<<a[i];
//			}
		j=0;
		c=u;
		for(;;){
			sum1(c);
			j++;
//			for(int i=0;i<u+1;i++){
//				cout<<a[i];
//			}
			//cout<<endl;
			int e=0;//用来记录每次加1之后有多少位1; 
			for(int i=0;i<u+1;i++){
				if(a[i]==1){
					e++;
				}
			}
			//if(e==w){
//			for(int i=0;i<u+1;i++){
//				cout<<a[i]<<endl;
//			}}
			if(e==w){
			//cout<<n<<" ";
			cout<<n+j<<endl;
			break;}
		}
		//if(n==100){
		//	break;
		//}
	}
//break;
//}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值