POJ 2453 An Easy Problem

题面链接:点击跳转
Description
As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1’s in whose binary form is the same as that in the binary form of I.

For example, if “78” is given, we can write out its binary form, “1001110”. This binary form has 4 '1’s. The minimum integer, which is greater than “1001110” and also contains 4 '1’s, is “1010011”, i.e. “83”, so you should output “83”.

Input
One integer per line, which is I (1 <= I <= 1000000).

A line containing a number “0” terminates input, and this line need not be processed.

Output
One integer per line, which is J.

Sample Input

1
2
3
4
78
0

Sample Output
2
4
5
8
83

解题思路
题面要求找二进制1的数量和n一样多,同时比n大的最小的数,那么就可以先把n转化成二进制,然后从最小位开始找哪一个二进制1的左边留了一个0,那么把这位左边的0改为1,然后再把右边所有1移到最右边,就能保证得到的是最小的.

代码如下

#include <iostream>
#include <cstring>
using namespace std;
typedef long long ll;
int c[65];
int main(){
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n!=0){
        memset(c,0,sizeof(c));
        int ans=0;
        while(n>0){//转成二进制
            c[ans++]=n%2;
            n/=2;
        }
        int sum=0;//记录找到前的2的数量
        for(int i=0;i<ans;i++){
            if(c[i]==1){
                c[i]=0;//先把1都去掉
                if(c[i+1]==0){//找到了改变的位置
                    c[i+1]=1;
                    break;
                }
                sum++;
            }
        }
        for(int i=0;i<sum;i++)c[i]=1;//把去掉的1加回去,加在末尾保证最小
        int res=0;
        int cnt=1;
        for(int i=0;i<=ans;i++){//加权转回十进制
            res+=cnt*c[i];
            cnt*=2;
        }
        cout<<res<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值