noi.openjudge 1455:An Easy Problem

http://noi.openjudge.cn/ch0406/1455/

描述

As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1’s in whose binary form is the same as that in the binary form of I.

For example, if “78” is given, we can write out its binary form, “1001110”. This binary form has 4 '1’s. The minimum integer, which is greater than “1001110” and also contains 4 '1’s, is “1010011”, i.e. “83”, so you should output “83”.

输入

One integer per line, which is I (1 <= I <= 1000000).

A line containing a number “0” terminates input, and this line need not be processed.

输出

One integer per line, which is J.

样例输入

1
2
3
4
78
0

样例输出

2
4
5
8
83

代码

#include<iostream>
#include<stdio.h>
using namespace std;

int n,p; 

int main()
{
	int i,q,m,r;
	while(1)
	{
		i=0;
		scanf("%d",&n);
		if(n==0)
			break;
		
		q=n;
		while(q)
		{
			if(q%2)
				i++;
			q/=2;
		}
		
		m=i;
		while(1)
		{
			i=0;
			n++;
			
			q=n;
			while(q)
			{
				if(q%2)
					i++;
				q/=2;
			}
			if(i==m)
			{
				printf("%d\n",n);
				break;
			}
		}
	}
	
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值