1032 挖掘机技术哪家强 (20 分)

题目:

样例:">样例:">输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

分析:简单模拟。

第一次:全过。

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int N = 0, index = 0, score = 0, num_max = 0;//定义的变量最好初始化
    cin >> N;
    vector<int> book(N+1, 0);
    while(N--){
        cin >> index >> score;
        book[index] += score;
        num_max = num_max < index ? index : num_max;
    }
    index = 1; score = book[index];
    for(int i=1; i<=num_max; ++i){
        if(score < book[i]){
            index = i;
            score = book[i];
        }
    }
    cout << index << ' ' << score;
	return 0;
}

第二次:使用一个循环,测试点数据没过。

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int N = 0, index = 0, score = 0,id_max = 0, score_max = 0;//定义的变量最好初始化
    cin >> N;
    vector<int> book(N+1, 0);
    while(N--){
        cin >> index >> score;
        book[index] += score;
        if(score_max<book[index]){
            score_max = book[index];
            id_max = index;
        }
    }
    cout << id_max << ' ' << score_max;
	return 0;
}

错误分析:问题在于每次输入一组数据都有可能导致该结果是最大值。因此当新输入的值更新之后且等于未更新时的最大值,就需要更新当前最大值的下标以及最大值。

正确代码:

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int N = 0, index = 0, score = 0,id_max = 0, score_max = 0;//定义的变量最好初始化
    cin >> N;
    vector<int> book(N+1, 0);
    while(N--){
        cin >> index >> score;
        book[index] += score;
        if(score_max <= book[index]){  //仅仅修改了判断条件
            score_max = book[index];
            id_max = index;
        }
    }
    cout << id_max << ' ' << score_max;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值