Road blocks 次短路

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
题目大意 :N个路口R条街道(双向),从1到N的次短路径和;

短路问题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int inf=0x3f3f3f3f;
const int N=100005;
typedef pair<int,int> P;
typedef struct node
{
    int to;//表示当前点
    int w;//每个容器的头节点到该点的距离,即输入时第一个点与第二个点的距离
} ed;
vector<ed>e[N];
int dis[N];//次短路
int dist[N];//最短路;
int n,m,a,b,c;
int dijkstra()
{
    memset(dis,inf,sizeof(dis));
    memset(dist,inf,sizeof(dist));
    dist[1]=0;
    priority_queue<P,vector<P>,greater<P> >h;//队列里的第一个数总是最小的;
    h.push({0,1});
    while(!h.empty())
    {
        P q=h.top();
        h.pop();
        int d1=q.first;//到该点的距离,
        int v1=q.second;//表示当前点,结构体里的to,pair里的第二个数
        if(d1>dis[v1])//到该点的路径大于次短路径;
            continue;
        for(int i=0; i<e[v1].size(); i++)//头节点为 v1 的点容器;
        {
            ed l=e[v1][i];//e[v1] 容器里的第 i+1 eg(结构体)
            int d=d1+l.w;// v1 点到达 i 点的距离
            int v2=l.to;
            if(d<dist[v2])//更新最小距离
            {
                swap(d,dist[v2]);
                h.push({dist[v2],v2});
            }
            if(d<dis[v2]&&d>dist[v2])//更新次短距离
            {
                swap(d,dis[v2]);
                h.push({dis[v2],v2});
            }
        }
    }
    return dis[n];
}
int main()
{
    cin>>n>>m;
    while(m--)
    {
        cin>>a>>b>>c;
        e[a].push_back(ed{b,c});
        e[b].push_back(ed{a,c});
    }
    cout<<dijkstra()<<endl;
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值