HDU 1075 What Are You Talking About(map)

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(’\t’), enter(’\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i’m fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i’m from mars.
i like earth!

思路

题中输入字典,然后去查找单词。字典用map存储,map可以自定义键值对的类型。主要是读入要查找的东西不易处理,需要将字母连成单词,还要将符合和空格换行等原样输出。这里用getchar()读入数据,getchar()可以一个一个字符读入(包括空格换行等),读入后是字母就存起来,如果不是就对之前存入的所有字母查字典,并将这个不是字母的东西输出

代码

#include<iostream>
#include<cstdio>
#include<string>
#include<map>
using namespace std;

map<string,string>m;					//定义一个map 

int main()
{
	char a[11],b[11];
	cin>>a;								//先读入start 无用 
	while(1)
	{
		scanf("%s",a);
		if(a[0]=='E')
			break;
		scanf("%s",b);
		m[b]=a;							//存入map中 
	}
	cin>>a;
	char tmp;
	string s;
	tmp=getchar();						//此处有个/n无用,先读入				
	while(1)
	{
		tmp=getchar();					//读入单个字符 
		if(tmp=='E')
			break;
		if(tmp>'z'||tmp<'a')			//不是字母 
		{
			if(s.size())
			{
			map<string,string>::iterator iter=m.find(s);
			if(iter!=m.end())			//寻找字典中是否有它 
				cout<<iter->second;		//将之前的输出 
			else
				cout<<s;				//没有原样输出 
			s.clear();					//!清空之前存入的字母 
			}
			cout<<tmp;					//把此位的那个字符输出 
		}
		else
			s+=tmp;						//是字母就记录下来,以便组合起来查字典 
	}
	cin>>a;								//读入后面的ND 无用 
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值