HDU 1075 What Are You Talking About

 

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 4539    Accepted Submission(s): 1368


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
  
  
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 

Author
Ignatius.L
 
 
OK! from now on, I will try to write in English, just for some pratice, because it will be a CET-4 in next term.
When you guys look  at the simple input and simple output, i think you have already know we must use Trie to solve this problem.
So the next step is simple , just "TYPE A Tire".
But at this time, i try another way to plant this tree!!!!So we have THREE Trie style!!!!!!!!!!
The new way's core is the "Pointer point to the Pointer". I will talk about it in detail in another post.
 
After you have planted the Trie, we must deal with the sentence. In my own way, easily, just use the function "isalpha()" which in "cctype", to seperate the lowcase from other characters.
 
So, Here is the code: 生气
43283182011-08-04 10:43:57Accepted1075328MS74688K1388 BC++10SGetEternal{(。)(。)}!
#include <iostream>
#include <string>
#include <cctype>
using namespace std;
#define MAXI 3030

class Trie
{
public :
    struct node
    {
        string key;
        node *next[30];
    } *root, **p;
    Trie() { Cre(root); }
    void Cre(node *&x)
    {
        int i;
        x = new node;
        x->key = "-1";
        for (i = 0; i < 30; i++)
            x->next[i] = NULL;
    }
    void Ins(char *key, char *tra)
    {
        int i;
        p = &root;
        for (i = 0; key[i]; i++)
        {
            p = &((*p)->next[key[i] - 'a']);
            if (*p == NULL) Cre(*p);
        }
        (*p)->key = tra;
    }
    string Que(const char *key)
    {
        int i;
        p = &root;
        for (i = 0; key[i]; i++)
        {
            p = &((*p)->next[key[i] - 'a']);
            if (*p == NULL) break;
        }
        if (*p) return (*p)->key;
        else return "-1";
    }
}zkl;

int main()
{
    char a[MAXI], b[MAXI], ste[MAXI];
    string w1, w2;
    int i;

    scanf("%s", ste);
    while (scanf("%s", a), strcmp(a, "END"))
    {
        scanf("%s", b);
        zkl.Ins(b, a);
    }

    scanf("%s", ste);
    getchar();
    while (gets(ste))
    {
        if (!strcmp(ste, "END"))
            break;
        w1 = "";
        strcat(ste, "\n");
        for (i = 0; i < strlen(ste); i++)
            if (isalpha(ste[i]))
                w1 += ste[i];
            else
            {
                if (w1 != "")
                {
                    w2 = zkl.Que(w1.c_str());
                    if (w2 == "-1") printf("%s", w1.c_str());
                    else printf("%s", w2.c_str());
                    w1 = "";
                }
                printf("%c", ste[i]);
            }
    }

    return 0;
}

It's not so hard all the way~~~RIGHT?!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值