Complete Binary Search Tree

description

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路

题目输入一串数字,使其为一个完全搜索二叉树顺序遍历的结果。
由于是完全二叉树,中间不中断,所以使用数组存树
先将输入的序列从小到大排列。计算出左子树的个数l,那么数组的第l+1位就是根结点。前l为就是左子树,l位之后的就是右子树。对左子树和右子树再分别按照之前的方法求根节点,
下面说一下怎么求左子树的结点个数。一个完全二叉树,每一层的总数都是确定的,对于第i行,第i行之前的所有结点数是2i-1。那么假设题中的树有h行,共n个结点,因为是完全二叉树,所以前h-1行肯定是完整的,假设第h行有m(0<=m<=2h-1)个结点,那么就有x+2h-1-1=n,h=log2(n+1-x)+1。因为肯定没有h+1行,那么h>=log2(n+1)+1且h<log2(n+1)+1,这样就可以得出第h行之前一共有多少行了。然后计算第h行之前一共k个,(k-1)/2就是第h行之前的左子树结点个数,再计算第h行左子树的结点个数,如果总结点减去第h行之前的个数小于第h行结点个数最大容量的一半,那么剩下的就都是左子树的,否则第h行的左子树最多就是第h行结点个数最大容量的一半。说了这么多,挺乱的,好像没说明白,就是求左子树结点个数,数学算一下,很好求的。

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

int a[1005],b[1005];								//a初始数组  b输出的数组 

int GetLeft(int n)									//求左子树的结点个数 
{
	double m=(log(n)/log(2));
	int h=(int)(m);
	int p=pow(2,h)-1;
	int r=n-p;
	int q=p+1;
	q/=2;
	if(r<=q)
		return (p-1)/2+r;
	return (p-1)/2+q;
}

void work(int start,int n,int pos)					//start该树中最小元素的下标  n结点个数  pos 所需树此次要排的位置 
{
	if(n==0)
		return;
	int l=GetLeft(n);
	b[pos]=a[start+l];								
	work(start,l,pos*2);
	work(start+l+1,n-l-1,pos*2+1);
}

int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
		cin>>a[i];
	sort(a+1,a+1+n);	
	work(1,n,1);
	for(int i=1;i<n;i++)
		cout<<b[i]<<" ";
	cout<<b[n];
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值