洛谷P1162 - 填涂颜色

题目描述

由数字 0 0 0 组成的方阵中,有一任意形状闭合圈,闭合圈由数字 1 1 1 构成,围圈时只走上下左右 4 4 4 个方向。现要求把闭合圈内的所有空间都填写成 2 2 2。例如: 6 × 6 6\times 6 6×6 的方阵( n = 6 n=6 n=6),涂色前和涂色后的方阵如下:

0 0 0 0 0 0
0 0 1 1 1 1
0 1 1 0 0 1
1 1 0 0 0 1
1 0 0 0 0 1
1 1 1 1 1 1
0 0 0 0 0 0
0 0 1 1 1 1
0 1 1 2 2 1
1 1 2 2 2 1
1 2 2 2 2 1
1 1 1 1 1 1

输入格式

每组测试数据第一行一个整数 n ( 1 ≤ n ≤ 30 ) n(1 \le n \le 30) n(1n30)

接下来 n n n 行,由 0 0 0 1 1 1 组成的 n × n n \times n n×n 的方阵。

方阵内只有一个闭合圈,圈内至少有一个 0 0 0

输出格式

已经填好数字 2 2 2 的完整方阵。

样例 #1

样例输入 #1

6
0 0 0 0 0 0
0 0 1 1 1 1
0 1 1 0 0 1
1 1 0 0 0 1
1 0 0 0 0 1
1 1 1 1 1 1

样例输出 #1

0 0 0 0 0 0
0 0 1 1 1 1
0 1 1 2 2 1
1 1 2 2 2 1
1 2 2 2 2 1
1 1 1 1 1 1

提示

对于 100 % 100\% 100% 的数据, 1 ≤ n ≤ 30 1 \le n \le 30 1n30

一、错误分析

题意就是把被1包围的0改成2。
那么只需要找到包围起来的第一个0的坐标,就可以把所有被包围的0改成2。
第一个0的坐标是第一个1的右下角?
那么就有了下面错误的代码,WA了一个测试点

//错误代码
#include <iostream>
#include <queue>
using namespace std;
int n;
int dir[][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};
int a[33][33];
struct node
{
    int x, y;
};
int main()
{
    cin >> n;
    int sx = 0, sy = 0;
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
        {
            cin >> a[i][j];
            if (a[i][j] == 1 && sx == 0)
            {
                sx = i, sy = j;
            }
        }
    sx++;
    sy++;
    // bfs广度优先
    queue<node> q;
    q.push({sx, sy});
    while (!q.empty())
    {
        node p = q.front();
        q.pop();
        for (int i = 0; i < 4; i++)
        {
            int nx = p.x + dir[i][0], ny = p.y + dir[i][1];
            if (!(nx>n||ny>n||nx<1||ny<1)&&a[nx][ny] == 0)
            {
                q.push({nx, ny});
                a[nx][ny] = 2;
            }
        }
    }
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= n; j++)
        {
            cout << a[i][j] << " ";
        }
        cout << endl;
    }
}

那么当墙有厚度的时候,这种找0的方法是错误的。
比如下面这组测试数据。

6 
1 1 1 1 1 1 
1 0 0 0 0 0 
1 1 1 1 1 1 
1 1 0 0 1 1 
1 1 0 0 1 1 
1 1 1 1 1 1 

二、正确分析

先将二维数组初始化为2,将有1的地方改为1,那么被1包围之外的2就是连续的了,只需要使用dfs或bfs就能够把所有包围之外的2改为0。
二维数组需要往外扩展一圈,这样就能保证包围之外的2是连续的。
如[1,n]的区间拓展为[0,n+1].

方法1.DFS

#include <iostream>
#include <queue>
using namespace std;
int n;
int dir[][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};
int a[35][35];
struct node
{
    int x, y;
};
void dfs(int x,int y)
{
    if(x>n+1||y>n+1||x<0||y<0) return ;
    if(a[x][y] == 1||a[x][y]==0) return;
    a[x][y]=0;
    for (int i = 0; i < 4; i++)
    {
        dfs(x + dir[i][0],y + dir[i][1]);
    }
}
int main()
{
    for(int i=0;i<33;i++)
    for(int j=0;j<33;j++)
    {
        a[i][j]=2;
    }
    cin >> n;
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
        {
            int t;
            cin >> t;
            if(t==1) a[i][j]=1;
        }
    dfs(0,0);
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= n; j++)
        {
            cout << a[i][j] << " ";
        }
        cout << endl;
    }
}

方法2.BFS

#include <iostream>
#include <queue>
using namespace std;
int n;
int dir[][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};
int a[35][35];
struct node
{
    int x, y;
};
int main()
{
    for(int i=0;i<33;i++)
    for(int j=0;j<33;j++)
    {
        a[i][j]=2;
    }
    cin >> n;
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
        {
            int t;
            cin >> t;
            if(t==1) a[i][j]=1;
        }
    queue<node> q;
    q.push({0, 0});
    while (!q.empty())
    {
        node p = q.front();
        q.pop();
        for (int i = 0; i < 4; i++)
        {
            int nx = p.x + dir[i][0], ny = p.y + dir[i][1];
            if (!(nx>n+1||ny>n+1||nx<0||ny<0)&&a[nx][ny] == 2)
            {
                q.push({nx, ny});
                a[nx][ny] = 0;
            }
        }
    }
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= n; j++)
        {
            cout << a[i][j] << " ";
        }
        cout << endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值