The Accomodation of Students-最大匹配+判断二分图

There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
思路:这道题就是判断一下是否是否为二分图,如过是的话进行一次最大匹配就可以了。
判断二分图用的方法是染色法,二分图相邻颜色不能相同,具体看代码
代码:

	#include<stdio.h>
	#include<string.h>
	const int N=600,M=5e4+10;
	int book[N][N],e[N][N],bk[N],match[N],n,head[M],cnt,color[N];
	struct l
	{
		int next,to;
	 }dis[M];
	 void add(int from,int to)
	 {
	 	dis[++cnt].to=to;
	 	dis[cnt].next=head[from];
	 	head[from]=cnt;
	 }
	 int dfs1(int u,int c)
	 {
	 	int i;
	 	color[u]=c;
	 	for(i=head[u];i!=-1;i=dis[i].next)
	 	{
	 		if(color[dis[i].to]==c) return 0;//判断相邻点是否相同颜色,如果相同直接返回0
	 		if(color[dis[i].to]==0&&!dfs1(dis[i].to,-c))//没有染色进行染色
	 		{
	 			return 0;
			 }
		 }
		 return 1;
	 }
	 int my()
	 {
	 	int i;
	 	for(i=1;i<=n;i++)
	 	{
	 		if(color[i]==0)//判断是否染过色,没有的话染色
	 		{
	 			if(!dfs1(i,1))//如果有相邻颜色相同,就不是二分图返回0
	 			{
	 				return 0;
				 }
			 }
		 }
		 return 1;
	 }
	int dfs(int u)
	{
		int i;
		for(i=head[u];i!=-1;i=dis[i].next)
		{
			int v=dis[i].to;
			if(bk[v]==0)
			{
				bk[v]=1;
				if(match[v]==0||dfs(match[v]))
				{
					match[v]=u;
					return 1;
				}
			}
		}
		return 0;
	}
	int main()
	{
		int m,i,j;
		while(~scanf("%d %d",&n,&m))
		{
			memset(book,0,sizeof(book));
			memset(e,0,sizeof(e));
			memset(match,0,sizeof(match));
			memset(head,-1,sizeof(head));
			memset(color,0,sizeof(color));
			cnt=-1;
			
			for(i=0;i<m;i++)
			{
				int a,b;
				scanf("%d %d",&a,&b);
				add(a,b);//用邻接表存一下
				add(b,a);
			}
			if(!my())
			{
				printf("No\n");
				continue;
			}
			int sum=0;
			for(i=1;i<=n;i++)
			{
				memset(bk,0,sizeof(bk));
				if(dfs(i)) sum++;
			}
			printf("%d\n",sum/2);
		}
	}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值