HDU-1016-Prime Ring Problem(DFS)

题目:

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

解题思路:

创建两个数组一个用来标记这个自然数是否被用过,用深搜进行遍历,继续深入的条件是当前值与上一个的和为素数,结束的条件是b[n]+1为素数,因为第一个数总是1;

错误分析:

小心输出格式,记得加换行。

完整代码:

#include<stdio.h>
int a[22]={0};	//标记每个数字只能用一次 
int b[22]={0};	//记录样例 
int bb(int m)		//正确 
{
	int i;
	if(m==1||m==0)
	{
		return 0;
	}
	for(i=2;i<m;i++)
	{
		if(m%i==0)
		{
			break;
		}
	}
	if(m==i)
	{
		return 1;
	}
	return 0;
}
void aa(int n,int k)
{
	int i,j,m;
	if(k==n-1)
	{
		m=1+b[k];
		if(bb(m))
		{
			for(i=0;i<n;i++)
			{
				if(i==n-1)
				printf("%d",b[i]);
				else
				printf("%d ",b[i]);
			}
			
			printf("\n");
			return ;
		}
		
	}
	for(i=2;i<=n;i++)
	{
		if(a[i]==0)	//判断这个数字是否使用过 
		{
			m=i+b[k];	//当前数字和前一个数字的和 
			if(bb(m)==1)	//如果是素数
			{
				k++;
				b[k]=i;
				a[i]=1;
				aa(n,k);
				k--;
				a[i]=0;
			 } 
		}
		
	}
	return ;
}
int  main()
{
	int n,m,i,j,k;
	j=1;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<22;i++)
		a[i]=b[i]=0; 
		b[0]=1;
		a[1]=1;
		k=0;
		printf("Case %d:\n",j);
		j++;
		aa(n,k);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小葛先生

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值