H - Digit Primes

A prime number is a positive number, which is divisible by exactly two different integers. A digit prime is a prime number whose sum of digits is also prime. For example the prime number 41 is a digit prime because 4+1 = 5 and 5 is a prime number. 17 is not a digit prime because 1+7 = 8, and 8 is not a prime number. In this problem your job is to find out the number of digit primes within a certain range less than 1000000.

Input

First line of the input file contains a single integer N (0 < N ≤ 500000) that indicates the total number of inputs. Each of the next N lines contains two integers t1 and t2 (0 < t1 ≤ t2 < 1000000).

Output

For each line of input except the first line produce one line of output containing a single integer that indicates the number of digit primes between t1 and t2 (inclusive).

Sample Input

3
10 20
10 100
100 10000

Sample Output

1 10 576

Note: You should at least use scanf() and printf() to take input and produce output for this problem. cin and cout is too slow for this problem to get it within time limit.

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define ll long long
const int maxn=1000005;
int vis[maxn],sign[maxn];
void init()
{
	memset(vis,true,sizeof(vis));
	for(int i=2;i<=maxn;i++)
		if(vis[i])
			for(int j=2;j*i<=maxn;j++)
				vis[i*j]=false;
}
bool ok(int x)
{
	int k=0;
	while(x)
	{
		k+=x%10;
		x/=10;
	}
	return vis[k];
}
int main()
{
	init();
	int t;
	cin>>t;
	for(int i=2;i<=maxn;i++)
		if(vis[i]&&ok(i))
			sign[i]=1;
	for(int i=2;i<=maxn;i++) sign[i]+=sign[i-1];
	while(t--)
	{
		int i,j;
		scanf("%d%d",&i,&j);
		printf("%d\n",sign[j]-sign[i-1]);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

郭晋龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值