Dungeon Master(BFS广度优先搜索)

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

 题目分析其实这是一道简单的三维BFS的题目,相比较与其他二维BFS迷宫问题,三维只是多加了一个楼层,那么我们就把二维转化为三维,其他的与二维迷宫差不了太多。详细解释在代码中,我已经解释得很详尽了,希望各位可以听懂。

	#include <iostream>
	#include <algorithm>
	#include <cstdio>
	#include <cstring>
	using namespace std;
	struct node
	{
	    int x;
	    int y;
	    int z;
	    int num;
	} link[40000];
	int op, tp, l, m,ll, n, flag, ans;
	int v[44][44][44];
	char st[44][44][44];
	int jk[6][3] = {{0, 1, 0}, {1, 0, 0}, {0, -1, 0}, {-1, 0, 0}, {0, 0, -1}, {0, 0, 1}};
	bool Judge(int dz, int dx, int dy)
	{
	    if(dx < 0 || dx >= m || dy < 0 || dy >= n || dz < 0 || dz >= l)
	    return false;
	    else
	    return true;
	}
	int main()
	{
	  //  int i, j, k;
	    while(scanf("%d%d%d", &l, &m, &n)&& (l != 0 || n != 0 || m != 0))//几个圈每个圈的行和列 
	    {
	        op = tp = flag = 0;
	        memset(v, 0, sizeof(v));
	        for(int i = 0; i < 40000; i++)//应该初始化 
	            link[i].num = 0;
	        for(int i = 0; i < l; i++)
	            for(int j = 0; j < m; j++)//有几个圈 
	                scanf("%s", st[i][j]);//每个圈 由多少行 
	        for(int i = 0; i < l; i++)//几个圈 
	            for(int j = 0; j < m; j++)//几行 
	                for(int k = 0; k < n; k++)//几列 
	                    if(st[i][j][k] == 'S'){
	                    	link[tp].z = i;//第几圈
	                        link[tp].x = j;  //第几行	                        
	                        link[tp].y = k;//第几列 
	                        tp++;
	                        v[i][j][k] = 1;//标记作用 
	                        break;
	                }
	         int x, y, z, i;
	    while(op < tp)
	    {
	        for(i = 0; i < 6; i++)
	        {
	            x = link[op].x + jk[i][0];//行
	            y = link[op].y + jk[i][1];//列 
	            z = link[op].z + jk[i][2];//圈 
	            if(Judge(z, x, y) && v[z][x][y] == 0)
	            {
	 
	                if(st[z][x][y] == '.')//s移动到这里了 
	                {
	                    v[z][x][y] = 1;
	                    link[tp].x = x;
	                    link[tp].y = y;
	                    link[tp].z = z;
	                    link[tp].num = link[op].num + 1;//加一分钟 
	                    tp++;
	                }
	                else if(st[z][x][y] == 'E')//终点 
	                {
	                    v[z][x][y] = 1;
	                    flag = 1;
	                    ans = link[op].num + 1;
	                    //cout<<ans<<endl;
	                    break;
	                }
	            }
	        }
	        //if(flag)//!=0
	            //break;
	        op++;//一套大循环加一次 
	    }
	        if(flag)//!=0
	            printf("Escaped in %d minute(s).\n", ans);
	        else
	            printf("Trapped!\n");
	    }
	   
	    return 0;
	}

  • 8
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 6
    评论
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法编程张老师

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值