At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format
HH:MM:SS
, andID_number
is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
方法一:(20分)
#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
int n;
cin>>n;
char a[n+1][20];
if(n!=1){
int maxs=0;
int mins=24*60*60;
int b1=0,b2=0;
for(int i=0;i<n;i++){
cin>>a[i];
int h1,m1,s1,h2,m2,s2,q,j;
if(scanf("%d:%d:%d %d:%d:%d",&h1,&m1,&s1,&h2,&m2,&s2)!=6){
cout<<"请重新输入";
}
q=h1*60+m1*60+s1;
j=h2*60+m2*60+s2;
if(q<mins){
mins=q;
b1=i;
}
if(j>maxs){
maxs=j;
b2=i;
}
}
cout<<a[b1]<<" "<<a[b2]<<endl;
}
else{
cin>>a[0];
int h1,m1,s1,h2,m2,s2;
if(scanf("%d:%d:%d %d:%d:%d",&h1,&m1,&s1,&h2,&m2,&s2)!=6){
cout<<"请重新输入";
}
cout<<a[0]<<" "<<a[0];
}
return 0;
}
方法二(结构体):
#include<stdio.h>
struct list{
char name[16];
int hh,mm,ss;
};
bool earlier(list a,list b)
{
if(a.hh!=b.hh) return a.hh<b.hh;
else if(a.mm!=b.mm) return a.mm <b.mm;
else return a.ss<b.ss;
}
int main()
{
int m;
scanf("%d",&m);
list first,last,temp;
first.hh=23,first.mm=60,first.ss=60;
last.hh=0,last.mm=0,last.ss=0;
while(m--){
scanf("%s",&temp.name);
scanf("%d:%d:%d",&temp.hh,&temp.mm,&temp.ss);
if( earlier(temp,first)) first = temp;
scanf("%d:%d:%d",&temp.hh,&temp.mm,&temp.ss);
if( !earlier(temp,last)) last = temp;
}
printf("%s %s",first.name,last.name);
return 0;
}
方法三(字符串操作):
#include<stdio.h>
#include<string.h>
#define Max 1006
char num[Max][15],in_time[Max][8],out_time[Max][8];
int main(){
int M,i,min=0,max=0;
scanf("%d",&M);
for(i=0;i<M;i++) scanf("%s %s %s",&num[i],&in_time[i],&out_time[i]);
// unlock door-min
for(i=1;i<M;i++)
if(strcmp(in_time[min],in_time[i])>0) min=i;
// lock door-max
for(i=1;i<M;i++)
if(strcmp(out_time[max],out_time[i])<0) max=i;
printf("%s %s",num[min],num[max]);
return 0;
}