Bone Collector(01背包问题-两种写法)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This

Bone Collector

HDU 2602

man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

多年前,在泰迪的家乡,有一个叫“骨头收藏家”的人。这个人喜欢收集各种各样的骨头,比如狗的,牛的,他还去了坟墓……
骨头收集者有一个V容量的大袋子,在他的收集之旅中,有很多骨头,显然,不同的骨头有不同的价值和不同的体积,现在给定每块骨头在他旅行中的价值,你能计算出骨头收集器可以得到的最大值吗?
输入

第一行包含一个整数 T ,即案例数。
接下来是T个案例,每个案例三行,第一行包含两个整数N,V,(N <= 1000 , V <= 1000 )代表骨头的数量和他的包的体积。第二行包含 N 个整数,代表每个骨骼的值。第三行包含 N 个整数,代表每个骨骼的体积。

输出

每行一个整数,代表总值的最大值(该数字将小于 2 31)。

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题意描述:给你骨头的数量和骨头收集器的体积,以及每个骨头的值和体积,求骨头收集器可以装的骨头的值的最大值

解题思路:01背包问题,可以利用二维数组或者一维数组来写

一维数组AC

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main(void)
{
	int t;
	scanf("%d",&t);
	while(t--)
	{	
		int n,v;//种类,包体积
		int dp[1050],p[1050],q[1050];
		memset(dp,0,sizeof(dp));
		scanf("%d %d",&n,&v);
		for(int i=1;i<=n;i++)
			scanf("%d",&p[i]);//价值 
		for(int i=1;i<=n;i++)
			scanf("%d",&q[i]);//体积 
		for(int i=1;i<=n;i++)
			for(int j=v;j>=q[i];j--)
				dp[j]=max(dp[j],dp[j-q[i]]+p[i]);
		printf("%d\n",dp[v]);
	}
	return 0;
}

二维数组AC

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[1050][1050];
struct Bone
{
	int v;//骨头的体积,
	int w;//价值	
}bone[1050];
int main(void)
{
	int t,n,d;
	scanf("%d",&t);
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		scanf("%d %d",&n,&d);//骨头的数量。包的体积 
		for(int i=1;i<=n;i++)
			scanf("%d",&bone[i].w);
		for(int i=1;i<=n;i++)
			scanf("%d",&bone[i].v);
		for(int i=1;i<=n;i++)
		{
			for(int j=0;j<=d;j++)
			{
				if(bone[i].v>j)//装不下的时候
					dp[i][j]=dp[i-1][j];
				else
					dp[i][j]=max(dp[i-1][j],dp[i-1][j-bone[i].v]+bone[i].w); 
			}
		}
			
		printf("%d\n",dp[n][d]);
	 } 
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值